Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Ubuntu 9.04 and I just noticed that ALL of my network traffic is being routed through my VPN. I would like the VPN to route only the traffic hitting servers on the VPN and then connect directly to anywhere else on the internet as needed. The VPN is PPTP VPN that is run using some sort of Microsoft stack.

Results from route command:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
102-102-152-203 192.168.24.1    255.255.255.255 UGH   0      0        0 wlan0
192.168.24.0    *               255.255.255.0   U     2      0        0 wlan0
link-local      *               255.255.0.0     U     1000   0        0 wlan0
default         *               0.0.0.0         U     0      0        0 ppp0
share|improve this question
    
You may be able to do something with your routing table. Would you mind running 'route' from your command line when you're connected to the VPN and putting the output up here? –  Mark Turner Jul 20 '09 at 22:00
add comment

4 Answers

up vote 9 down vote accepted

For my Cisco Compatible VPN in Ubuntu 9.04 (VPNC), there is a check box to select.

Edit your connections, go to the VPN tab, and edit the VPN configuration.

Go to the IPv4 Settings tab, and in the bottom right is a button "Routes".

Click the button and check the box "Use this connection only for resources on its network"

As others have mentioned, there are text based configuration files one can alter instead of using the GUI. One nice thing about GUIs is that you don't have to memorize all the possible values or worry about spelling

share|improve this answer
    
can you give a reference of how to do it in command line - i mean "Use this connection only for resources on its network" –  cc4re Jan 11 at 7:11
add comment

Thanks to the advice in the above answers and a bit of searching on my own, I was able to find the answer to my own question.

First, I determined what ip address ranges were being used on the VPN, in my case 192.168.32.* and 192.168.16.*. Then I connected to my vpn normally and sshed to a server on the network. I ran route on that machine and got the gateway address and metric being used. Then I added routes for the two ip address ranges to the routes field in the IPv4 settings tab and clicked on "Use this connection only for resources on its network" and "Ignore automatically obtained routes". Then poof like magic it worked.

Thank you all for your help!

share|improve this answer
    
Thank you! I've been trying to do this for ages. I also had to set the "Method" to be "Automatic (VPN) addresses only", and left the DNS servers and search domain blank. –  Timmmm May 10 '11 at 12:58
add comment

If you want to do a block edit, export or simply a backup the details are in this folder /etc/NetworkManager/system-connections/

To apply changes if any you should do

sudo NetworkManager stop
sudo NetworkManager start

share|improve this answer
add comment

I'm assuming the pptp software is setting your default route to ppp0.

You can either tweak your routes after your connection

or

you could try removing the 'defaultroute' directive from the pptp config file (possibly /etc/ppp/ppp.conf)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.