Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am now connecting to my laptop to my modem using a cable without a router. Testing TCP and UDP in emule fails

Starting TCP connection test...
TCP test failed! UDP test will not be performed.


Connection test finished.

Results in detail:

* TCP connection test failed.
  It was not possible, to establish a TCP connection to your eMule.

Some remarks:

My operating system is Windows 7. In "Windows Firewall with Advanced Security" that both TCP and UDP for emule have "All Ports" for "Local ports" and "Remote ports". I am not sure if I have other firewalls working too. How to check that?

I have turned off the firewall in my modem, which is Motorola SBG900.

my laptop is from Lenovo. Does the lenovo system software have its own firewall?

my ISP is comcast cable, not sure if emule's default TCP port 17423 and UDP port 11391 would be banned?

my antivirus software is Windows Security Essentials, where I didn't see it has any firewall.


I use the software CurrPorts to see the usage of ports on my computer. Below is a screenshot. Is it normal that the Local Address for emule is 0.0.0.0?

alt text


Thanks, harrymc!

(1) But I have turned off the firewall of the modem, does the modem still place restriction on port forwarding?

(2) when I try to specify the ports of emule in this modem, I did not find places to specify which is the protocal, TCP or UDP, for each port. Instead I find an option called "Template", which let me choose one from HTTP, FTP etc but not TCP and UCP. Where can I input TCP or UDP? And which one should I choose for "Template"?

(3) Now I am connecting a router Linksys WRT54GL to the modem via a cable and connecting my laptop to the router via wireless network. In the Linksys router for each port I have to specify the IP Address in the form of 192.168.1.x, which I guess it is the one of my laptop, which is 192.168.1.102? If I have to specify the ports of emule again in the modem, is the "LAN ip address" in the form of 192.168.0.x the same as the ip of my laptop when it is connected to the modem by cable directly without using Linksys router? I tried the above but TCP test still fails not to say UDP. If I want to specify the ip to be any number in the last field, i.e. all 192.168.1.x for router and all 192.168.0.x for modem, how to specify them?

share|improve this question
    
Since you edited your question, I'll edit my answer ;) –  Ƭᴇcʜιᴇ007 Jan 15 '10 at 5:30

3 Answers 3

Your router is going to also act as a firewall, so you'll have to open the ports in it as well. Check out PortForward.com for help, they may even have pre-made instructions for your particular router.

Edit:

From Portforward get the PFPortCheck utility, turn off eMule and use the port checker to test your eMule ports, it will at least help you eliminate eMule as your problem point.

Then, after testing with Portchecker instead of eMule, turn OFF the Windows firewall to eliminate it as a suspect (in case one of the rules you mentioned is misconfigured) and test again.

Unfortunatly there's no 'one way' to check if you have any other firewalls running.

share|improve this answer
    
But I am connecting my laptop to a modem without using a router. If it does not work without a router, how can it work with one. –  Tim Jan 15 '10 at 3:42
    
My fault, I thought it said WITH a router. :) Me = dummy. I will add here, you can pick whatever ports you want in eMule, so if you're concerned they are banning certain ports, you can just use others. Usually ISPs don't do this anymore anyway, they let it through and then use their routers shape/limit the eMule traffic, regardless of it's port. –  Ƭᴇcʜιᴇ007 Jan 15 '10 at 4:06
    
Thanks, techie007. When the emule is not running, giving its ports to PFTportCheck will see message like "your port is not open or not reachable". When the emule is running, PFTportCheck "could not test port xxx because some other application has the port locked." Does this mean the my laptop does not block the ports of emule? –  Tim Jan 15 '10 at 7:39

@Tim: Your modem is misnamed "cable modem", but it's really a router.
You must forward the eMule ports to your computer.

From its manual:

Gateway > PORT FORWARDING — status Page

Use this page to display the configured port forwarding entries on the SBG900 LAN. The fields are the same as on the Gateway > PORT FORWARDING — config Page:

image

EDIT

You can have only one DMZ computer.
What you should do:

  • Ensure that only the modem box distributes DHCP IP addresses so all machines are on the same network segment (if I understood correctly that's the one that's connected to the internet).
  • The router shouldn't set itself up as DHCP server and shouldn't try to give itself the same IP address as the modem.
  • In the modem config, set the DHCP server modem to fix the IP of the designated DMZ machine to be always the same.
  • In the modem config, define the designated machine as DMZ.

This is it.

share|improve this answer
    
Thanks, harrymc. Please see my update to the original post. My questions are a bit long and cannot be input in comment. –  Tim Jan 15 '10 at 7:34
    
Port Forwarding has to be defined (by default there is none). For each port you must specify the internal IP of the handler computer. You can normally also specify one DMZ computer that handles ALL ports. –  harrymc Jan 15 '10 at 8:50
    
Thanks harrymc! So in this case when modem is connected to router by cable and laptop connected to router by wireless network, what would be the DMZ computer? Shall I add another DMZ computer? –  Tim Jan 15 '10 at 17:05
    
There can be only one DMZ computer - you need to choose. But I rather suggest that you do it by ports, but since one specific port can only be forwarded to one computer, so you need to use different ports for eMule for the two computers. The DHCP master must be the router since it's connected to all the other players and so forces them all all into one and same network segment (or there is no connectivity). –  harrymc Jan 15 '10 at 21:26

type 192.168.1.1 in your browser. see what pops up (usually will ask for a password). see what model router you have - as techie007 already suggested, go to portforward.com and try to find instructions on how to enable port forwarding for that specific model. do a test at portforward.com for that port.

try then and let us know what happens ...

share|improve this answer
    
I am now connecting my laptop to a modem without using a router. –  Tim Jan 15 '10 at 3:45
    
just so we're clear ... you're using an adsl modem or an actual modem (56 kbps, 48kbps ... those) ? –  ldigas Jan 15 '10 at 3:48
    
what model is your modem ? –  ldigas Jan 15 '10 at 3:49
    
,I am using Comcast cable modem. It is Motorola SURFboard SBG900, Software version: SBG900-2.1.15.0-SCM00-NOSH, Hardware version: 3 –  Tim Jan 15 '10 at 3:57
    
What happens still when you try to access localhost (192.168...) ? Can you access its interface in any way ? I found the manual, for it here, and it has a chapter on port forwarding (pg 14): motorola.com/Consumers/US-EN/Consumer-Product-and-Services/… For a list of open ports on your computer (not your modem) you can use this thing: nirsoft.net/utils/cports.html –  ldigas Jan 15 '10 at 4:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.