Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I took my SQL Server 2008 offline because I was trying to do something... Now I can't log in to it using SQL Server Management Studio anymore. "The server was not found or was not accessible." I'm not sure exactly what I did, but whatever I did, I need to undo it.

I recall right-clicking on the connection in SMSS and hitting "Stop". Now I can't get it up again.

Any help appreciated.

share|improve this question
add comment

2 Answers

You need to start the SQL Server Windows service.

Start the Services control panel applet (or "services.msc" from Start|Run). Right click on "Services (local)" to connect to the right computer.

Go down the list and start "SQL Server (MSSQLSERVER)", assuming you are using the default instance.

If you cannot connect remotely you will need to visit the machine.

Additional:

  • Ensure a firewall is not blocking connections.
  • Ensure the network protocol you are using is enabled on the server (full SQL Server has an app for this).
  • Can you connect locally?
share|improve this answer
    
I'm using SQLEXPRESS and service "SQL Server (SQLEXPRESS)" is already started. I tried restarting it as well, with no luck. –  howdy Jan 15 '10 at 11:02
    
Expanded... in the end I think you will have to go back to basics and double check everything (starting with anything you are assuming: e.g. check the process exists, not just the service is running). –  Richard Jan 16 '10 at 10:48
add comment

Check what you did against this article:

SQL SERVER – FIX : ERROR : (provider: Named Pipes Provider, error: 40 – Could not open a connection to SQL Server)

share|improve this answer
    
Sorry, none of those tips solved the problem. Some of them don't even apply to me since I'm connecting to the server locally. I recall right-clicking on the connection in SMSS and hitting "Stop". Now I can't get it up again. –  howdy Jan 15 '10 at 10:15
    
If you're connected locally, then have you tried rebooting? –  harrymc Jan 15 '10 at 10:45
    
Yes, I tried rebooting, but no cigar. –  howdy Jan 15 '10 at 10:47
1  
Apparently I was remote desktoping to the wrong computer. facepalm Thanks. –  howdy Jan 15 '10 at 12:16
1  
Just don't forget to accept the answer. –  harrymc Jan 15 '10 at 12:17
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.