Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How i can disable Screen lock feature in Windows XP instantly?

I tried importing this to registery:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableLockWorkstation"=dword:00000001

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableLockWorkstation"=dword:00000001

But this doesn't work and user can still lock the computer.
I tried this on Windows 7 and surprisely it works fine!

Note: I know it can be done easily with gpedit.msc and editing Group Policy setting, but I need a solution that can be done programatically easily (like registry modifying).

Note2: The solution should disable/enable lock feature instantly. It should not need any logoff/reboot to take effect. The registery editing work fine and immediately in Win7 but it doesn't work in my Windows XP.

UPDATE: I figured out when i disable Fast User Switching feature, the problem solves and i can disable/enable Lock feature instantly (the registry way).

But the question still holds when the Fast User Switching is not disabled.

share|improve this question
    
Have you tried rebooting the users' PC? If after rebooting, if it still doesn't work, has the registry value changed? –  Mark Jan 15 '10 at 15:03
    
I've logged of/rebooted PC but doesn't work. But the solution also should not need any logoff/reboot to allow/deny lock. it should have ability to enable/disable this feature instantly. registery editing works great in Win7 but i don't what's wrong with the Windows XP. –  Isaac Jan 15 '10 at 15:23
add comment

2 Answers 2

This is a bug in XP. They claimed it was going to be fixed:

This problem was first corrected in Microsoft Windows XP Service Pack 2.

Either it wasn't fixed or they subsequently re-broke it. I have an SP3 XP box here and it doesn't work. They have a hotfix you can download but it won't install because it's older than the currently installed file. If you would like to try it yourself, here's the link to the KB article:

You can lock the computer even when the Disable Lock Workstation policy setting is in effect in Windows XP

share|improve this answer
    
So what i have to do to solve this problem? :( –  Isaac Jan 19 '10 at 10:04
    
@Isaac: From what I read, uninstalling SP3 might fix the problem, although I'm not positive about that. Even if did fix it, I'd say that's an unacceptable solution. You may have to just wait and see if Microsoft addresses the issue in a future patch. –  raven Jan 19 '10 at 13:52
    
@raven: The problem solved by disabling Fast User Switching feature. Thanks anyway. –  Isaac Jan 30 '10 at 14:30
    
@Isaac: Cool. That's good to know. You should answer your own question and then except it when you can in a couple days. –  raven Jan 30 '10 at 17:27
    
@raven: thanks but i think it is still a bug for windows XP. disabling lock feature should not depends on fast user switching. So the question remains somehow open ;) –  Isaac Jan 31 '10 at 7:19
show 1 more comment
up vote 0 down vote accepted

This problem is solved by disabling the Fast-User-Switching feature. maybe it seems awkward and unrelated, but there is really a reason!:

When the Fast-User-Switiching is enabled, other users needs to Lock this user to start a new session and login. So it is meaningless that we deny Lock permission while FUS is enabled.

So, anybody who want to disable Lock would also forget about FUS and disable it too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.