Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed MS Office 2010 Beta (OneClick technology). All apps launch from 1 program, Word for example has this link:

"C:\Program Files (x86)\Common Files\microsoft shared\Virtualization Handler\CVH.EXE" "Microsoft Word 2010 (Beta) 2014006204190000"

Or OneNote:

"C:\Program Files (x86)\Common Files\microsoft shared\Virtualization Handler\CVH.EXE" "Microsoft OneNote 2010 (Beta) 2014006204190000"

Because of that I can't associate files with Office programs in file properties, they actually associate with “Microsoft Office Client Virtualization Handler” (CVH.EXE).

Anyone know another way to do that?

share|improve this question
1  
Final release have no problem with this. –  Semyon Perepelitsa Jun 20 '10 at 10:18
add comment

3 Answers

Are you sure you have the 64-bit version installed? It looks like the files were installed in the x86 program files directory, which only exists on 64-bit Windows. There's a 64-bit version of the Office beta available. It's possible that would work better.

If you already have the 64-bit edition, try this. It should work:

Choose which document type you want to set this for. Set it to open CVH.EXE. Open the registry editor. Go to HKEY_CLASSES_ROOT.docx (for example - replace .docx with whichever extension applies). See what the REG_SZ value (Default) is set to. By default it will be something like Word.Document.12, but it may be something different on your system. Then, go to HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command (replacing Word.Document.12 with whatever the value was you got from the last step). Edit the REG_SZ value "default" to whatever you want the command to be; in your case, probably "C:\Program Files (x86)\Common Files\microsoft shared\Virtualization Handler\CVH.EXE" "Microsoft Word 2010 (Beta) 2014006204190000" %1. (%1 is the filename which you are opening)

That should work! If it doesn't, I'll see if I can come up with any other ideas.

share|improve this answer
    
It seems like HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command does not belong to .docx (if i change command in registry, file is still opening with old program; if I change program in file properties, nothing changes in this registry item). HKEY_CLASSES_ROOT\.docx default field shows Word.Document.12 and file has .docx extension. Didn't find where can I download 64-bit version. On microsoft.com I downloaded X16-NNNNN_CCCCC-CCCCC-CCCCC-CCCCC-CCCCC.exe (N - number, C - number or letter), I wasn't asked to choose version. –  Semyon Perepelitsa Mar 14 '10 at 7:09
    
It depends on where you download it from. I downloaded it from TechNet, where there is an option to choose. See technet.microsoft.com/en-us/evalcenter/ee390818.aspx, click on "Get Started Now", log in, then select the 64-bit download. This may work better for you overall anyways. What is associated with the registry entry mentioned? What is currently opening .docx files? Try searching in the HKEY_CLASSES_ROOT key for the name of the executable you set the word docs to open with - the handler application. Does it appear anywhere? –  nhinkle Mar 14 '10 at 20:27
    
Any luck with this? –  nhinkle Mar 19 '10 at 8:17
    
I've created an empty .com file (unique_name.com on desktop) and associated .docx with it. I found something interesning in HKEY_CURRENT_USER. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.‌​docx\UserChoice contained unique_name.com. HKEY_CLASSES_ROOT\Applications\unique_name.com\shell\open\command contains full path to program "C:\Users\Sema\Desktop\unique_name.com" %1. All Office apps launch from one .exe with different parameters, I think it is impossible to separate each extension to open exe with it's own parameters. –  Semyon Perepelitsa Mar 20 '10 at 16:25
add comment

I had the same problem on Windows 7 OS. I managed to fix it by simply going to Control Panel/Uninstall Program, right clicking on MS Office and choosing the "change" option, this then performed a "repair" of the application and the association issue was fixed.

share|improve this answer
add comment

not sure if this answers you question, but i had a similar problem of not being able to alter my default program settings for ms office programs, like you mention due to the virtualisation handler. Instead of fiddling in my registry i chose to get rid of the virtualisation handler. To do so you have to deinstall and instaal some office programs, see detailed instructions at: http://social.technet.microsoft.com/Forums/en/office2010/thread/0d2708ec-13d8-41dc-a62a-32792975801b hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.