Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I adjust the contrast and brightness of a monitor in Ubuntu if the drivers are just for Windows?

Is there software that can do it without having to use the graphic drivers?

share|improve this question
    
What about the contrast? –  Georg Schölly Sep 7 '10 at 21:48
    
My Dell 13z laptop won't allow me to increase the brightness when in a Linux distro. Ubuntu is convinced that it's already at maximum brightness. I can however change it (using the Fn key combo) while BIOS is loading, so at least I don't need to boot into Windows to do it. –  Kenny Rasschaert Sep 7 '10 at 21:56
add comment

7 Answers

It would really help to know what sort of laptop you have, which video card, which monitor and whether you are on Gnome/KDE.

If you are using Gnome, the Gnome Color Manager could be a solution (not available with all gnome versions).

If you are using KDE with LCD, the luminosity applet KLcdDimmer might be a solution.

The gamma level may be adjustable with the xgamma command (not available with all video cards).

If you are using nvidia, you could edit ~/.nvidia-settings-rc, and call nvidia-settings --load-config-only.

For sony vaio the brightness and volume function keys may exist with installing fsfn.

You can search for a better video driver for your card on X.Org. Some of them have a bundled utility to adjust gamma/contrast/brightness.

share|improve this answer
add comment

Is it an LCD monitor? You can try this from the command line:

$sudo echo -n 100 > /proc/acpi/video/VGA/LCD/brightness

If it's too bright use a lower number. If you have GLX instead of VGA the file is /proc/acpi/video/GLX0/LCD/brightness.

share|improve this answer
add comment

Use

sudo setpci -s 00:02.0 F4.B=xx

Where xx is the desired brightness in hexadecimal ranging from 00 (brightest) to FF (no brightness at all).

share|improve this answer
add comment

Just a few hours ago, I installed Quantal Quetzal Ubuntu, I just went to dash home and typed "settings" and selected the Power Settings, then clicked the "Brightness Settings" link and finally adjust the desired brightness.

share|improve this answer
add comment

There is a workaround that might work for you in this bug report. This relies on adding acpi_osi=Linux to the kernel boot option. Others seems to have more success with these options: nomodeset acpi_backlight=vendor

These options can be passed via Grub. You might want to try them out by editing these commands in the Grub menu before putting it in Grub's configuration file.

share|improve this answer
add comment

@Bruno is right. I experienced the same problem when using Fedora 17. The keyboard hotkeys for brightness would not have any change on the brightness. Do a simple edit of your grub file as explained at http://joseblog.netau.net/tips-and-tricks/acer-adjust-brightness-problems.php

share|improve this answer
1  
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Canadian Luke Aug 13 '12 at 22:57
add comment

If you are using Ubuntu go to System > Preferences > Power management there you find a brightness bar slider set it to the desired brightness level and to keep the change permanent check on the Make default check box

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.