Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I replaced an old SpeedTouch ADSL router with a Netgear DG384 that I have and whilst doing so decided to change the wireless password. For this question assume my wireless network SSID is DeddersHome.

On my netbook and macbook pro (running Win7) it won't connect to the Internet. When I hover over the tray icon for wireless it says "DeddersHome 2" and "DeddersHome 3" have no internet connection.

What are these additional wireless networks? I can't see them in the wireless network list on any wireless device I have.

Wired connections and wireless through my iPhone work fine.

I saw this before with the SpeedTouch, but it just went away!!

I also have one Apple AirPort Express connected to the wireless network which my Xbox is connected to (wired).

This all worked before... I am going to remove AirPort to see if it is this causing the problem, but thought I'd ask the question to give it time for an answer whilst I continue to search.


share|improve this question
Removed AirPort express and devices now connect, but still say "DeddersHome 2", but show as connected to DeddersHome in wireless network list???? :S – neildeadman Jan 16 '10 at 13:46
Check maybe you have some settings in network connections, saves under names of those networks. Delete those settings (leaving the one you need), and I think it may cause them to go away. – Rook Jan 16 '10 at 14:01
@ldigas: tried that, only the two different wireless networks I use (home and work) were listed. Removed them both (just to be sure) but when I reconnect, it still happens. – neildeadman Jan 16 '10 at 14:05
I also tired this with the AirPort Express removed, and it still comes up with this second wireless network, but is connecting to Internet! – neildeadman Jan 16 '10 at 14:18

Go into your advanced wireless settings, remove all references to your network and then reconnect as you would normally this usually fixes any issues.

share|improve this answer
I did try this, but it never worked. It still added it as a second version of that SSID. – neildeadman Jul 11 '11 at 10:34

I got weird behaviour like this until I renamed the SSID. That seemed to clear the settings on the clients.

share|improve this answer
Right I will give that ago today then. By chance, I don't suppose you also use a AirPort Express? If not, at least that hopefully means its not that causing the issue! – neildeadman Jan 17 '10 at 12:12
I use a Buffalo router running Tomato, but I think this is more of a problem with the wireless clients, not the server. – Iain Jan 17 '10 at 14:54
Changed the SSID and all devices show using this network and not a 2nd or 3rd version of it. Just need to add the AirPort Express back to the network to see what happens... – neildeadman Jan 18 '10 at 11:39

Windows 7 and possibly Vista as well incorporate some behind the scenes checks on which AP is serving that SSID and whether they are all part of the same network or not, making it a "feature" to make it possible to choose between networks that incorrectly advertise the same SSID even though they are different networks (as may often be the case if a default or generic SSID is used). Completely removing the network and then re-associating on the clients may fix it. discusses the issue and other possible solutions in more detail.

share|improve this answer
I never got to the bottom of what caused the issues, but have since changed ISP so now have cable with a new router. At the time I did remove all entries for all wireless networks and still it got added as 'DeddersHome 2'. Very strange! – neildeadman Jul 11 '11 at 10:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.