Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 + Windows Media Center for my HTPC. It works great except from one annoying issue. Whenever I turn off my TV while listening to music, the music stops for a second or while Windows 7 tries to figure out what monitor is attached. After that second it settles down on a default 800x640. While not a big deal, it is annoying as I don't want to have the TV on while playing music.

Is there anyway to fix the monitor/disable monitor auto-detection on Windows 7 so it would not start recalibrating everything when I turn off my TV?

share|improve this question
    
Related: superuser.com/questions/120983/… –  Billy ONeal Oct 18 '10 at 16:48

8 Answers 8

Add an EDID emulator with HDCP between your monitor/display and PC will solve this issue.

The emulator will keep feeding HDCP and EDID info of your monitor, so your system (specially for Windows 7) will still "think" the monitor is on, even you power-off your monitor.

More and More OSs (such as Windows 7 and some linux...) request to check the connected devices' status frequently and automatically (not just checking the display status, but also checking USB keyboard/mouse or speaker....etc). If devices are turn-off or disconnected from the PC system, the OS will issue a HPD (hot-plug Detect) error. So far, there still no way to turn this feature off under Windows 7.

share|improve this answer

You can disable the auto-detection feature of your graphics card through the advanced display properties or the driver management utility.

If yours is a ATI card, check the Catalyst Control Center:

alt text

share|improve this answer
    
Molly, thanks for answer. Sadly it doesn't work. BTW - which version of Catalyst is this? mine looks very different. (and yes I have an ATI radeon hd 4550 card). –  Boaz Jan 17 '10 at 22:09
    
since the screenshot shows a radeon x1800, i suppose it's about 3 or 4 years old. did you go through all options of the catalyst control center? i only have 1 ATI here, a radeon hd 4360, which happens to be in an older XP machine. ATI CCC requires dotnet frameworks which is a 'no no' for me so i can't check right now. :) –  Molly7244 Jan 17 '10 at 22:37
    
The latest CCC in windows 7 is very different, it also has some weird options hidden, light right clicking on the display icons in the desktop and graphics tab. –  zimmer62 May 4 '10 at 19:26
    
Yeah, this doesn't work. I'm guessing the setting is purely for monitor detection within CCC. (...FYI, anyone who stumbles upon this -- I realize this is a 3+ year old thread) –  Coldblackice Oct 4 '13 at 0:12

I have a solution but I don't know if it only works for me.

You have to setup in display/screen resolution your monitors(plasma whatever) to be generic non-pnp monitor

For example: I started Windows 7 with my monitor closed and plasma didnt get recognized

And I didn't clicked on detect, I leaved the greyed out display and just select the option:

multiple displays:extend these displays

I also did that before with my main display Sony CRT monitor.

So now I can start Windows with everything turn off and when Windows 7 loads up and i turn on my plasma and sony crt everything is in place

And doesnt get undetected.

If your generic non-pnp monitor doesnt give you resolutions you need you can create them (custom resolution) with Nvidia control panel.

share|improve this answer
    
Interesting. I know this is old, but would you mind expounding on this a bit more? –  Coldblackice Oct 2 '13 at 17:46

This just in! Block pin 19 on your hdmi cable with a small piece of electrical tape

like so

http://postimage.org/image/2g8p5dwdg/

This pin is responsible for sending on/off signals

Not my solution but I thought I would take a minute to propagate working intel as this solved the headache for me

share|improve this answer
    
Interesting! Where'd you hear or find this? –  Coldblackice Oct 3 '13 at 4:22

Add this reg entry by typing in regedit into the start search bar and hitting enter:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TMM]
"UseIViewHelper"=dword:00000000
@="0"
==========================================================================

or save:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TMM]
"UseIViewHelper"=dword:00000000
@="0"

in a .reg file (if your folder extensions are visible). If they're not - go to the folder you're in (Organize > Folder and Search Options) and enable "Show extensions for known file types".

You can now save this file as .txt and rename to .reg or whatever method you may choose to save this as a registry file.

When you double click on a registry file, it asks you if you want to enter this into the system registry - Say yes.

share|improve this answer
1  
This doesn't work for 7, only for Vista –  Billy ONeal Oct 18 '10 at 16:47
    
If you want to skip a step of Remaining to a .reg file when you are saving the text file You can put "'s around the name of the file to force the .reg type for instance be default it will be [blah.text] make it ["blah.reg"] –  Xiuhtecuhtli Jan 6 '11 at 19:03

Have a look at your services, the graphics card may have a service to detect this such as "AMD External Events Utility" or "ati hotkey poller". Disable it and see if that makes a difference.

share|improve this answer
    
I have NVIDIA NVS 300 video card and stopping NVIDIA Windows services stopped this annoying behavior. –  lowleveldesign Oct 1 '12 at 13:20

This fixed it for me.

Newest version of Catalyst Control Center as of today. 6-24-2014 Preferences - Advanced View

Left side column - Open My VGA Displays - Click on properties (VGA Display)

Uncheck EDID

Set display size and frequency. I recommend 60 hz unless you know for sure it can handle other frequencies as this is default for any monitor.

share|improve this answer

open regedit and find

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Video{XXXX...}\0000 ( 'XXXX' means device number. There are several device number folder and u should find 'AdapterDesc' in 0000 folder which key value is 'amd radeon HD 7XXX Series'. )

At that '0000' folder, Change 'PP_SclkDeepSleepDisable REG_DWORD' value 0 to 1. and reboot!

worked for me

share|improve this answer

protected by Mokubai Jul 8 at 19:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.