Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a 5.1 surround sound speaker set for my computer in my bedroom. The rear speakers are next to me in bed while the front speakers are at the other end of the bed at my feet. While I enjoy the surround sound during movies that support 5.1 sound, I would like to have my rear speakers working when listening to podcasts, or other 2.1 channel sound. How can I do this? When I enable "Speaker Fill" in the Realtek Hd Audio manager the sound only comes out of the front and center speakers with a few background noises that come out the rear ones. But since my ears are closer to the rear speakers, I'd rather have the sound come out of them.

Let me know of any ideas!

Hmm seems like the only option is to set the rear speakers to "Front Speakers" and change it to stereo in the Realtek HD audio. But still that take alot of steps and it doesnt not use the center speaker Thanks

share|improve this question

12 Answers 12

up vote 11 down vote accepted
+100

This might not be exactly what you're after, but there is a Winamp plugin for Windows Vista/7 that provides various options for upmixing stereo signals to 5.1 (and higher), you might just be able to make out the configuration options from this blurry screenshot:

VL Sound 5.1 Setup

share|improve this answer
    
Kewl plugin, it did exactly what I wanted!! I'm going to wait and see if some one has a more universal solution, if not you will definitely get the bounty. THanks! –  thegreyspot Feb 3 '10 at 4:58
    
Glad it helped, it does seem like there should be a broader solution, I'll keep looking –  Rich Seller Feb 3 '10 at 12:27
    
@bobobobo It’s not the function of driver, but the app. Performing such functions in the driver would make playing 5.1 sound impossible. –  kinokijuf Mar 2 '12 at 22:54

Usually with a 5.1 speaker system on the Realtek HD,
you should get an upmix of your stereo and 2.1 audio.
Check this AVSForum discussion on Disable stereo upmix on Realtek HD Audio?

The Reaktek control app has options to select the Audio I/O for various number of channels. Maybe you need to change this to 5.1?

If you are using Windows Vista, i came across this weird discussion on
Vista and Realtek HD audio cannot provide surround sound

share|improve this answer
    
I have "speaker Configuration" set to 5.1 Speaker. I do not see any options for "upmix", can you point me in the right direction? thanks! –  thegreyspot Jan 19 '10 at 5:08

In my case, I was having the same problem, my music and most videos were on 2.1 and I only heard 2 of the 5 speakers. Videogames and some videos had 5.1 so no problem.

If you're running Win7 and you have no other than the default sound driver, there is an option "Speaker Fill" that solves all problems!

First, right click on the sound icon in the task bar (right lower corner), choose "Playback Devices".

If you have only one sound output, it'll be the only one on the list. If you have more than one then, while playing some music, you'll notice one of the device's volume bar moving, that's the one you should select.

Select your audio input and click on "Properties". Then go to "Enhacements" tab. There should be a checkbox with the "Speaker Fill" in the middle. Select it and press apply.

Worked for me perfectly, 5.1 sound on 2.1 music =D

share|improve this answer
    
This worked for me. Uninstall the realtek driver and use the windows default. –  Gerbus Sep 8 at 4:39

It's completely non-software, but what about getting an audio source switch from a place like Radio Shack and have the front and rear speakers go through it between the computer and you, so that when you're doing a non-5.1 sound activity, you can manually just switch the speakers to put the "front" near you?

share|improve this answer

If you use the realtek, download the realtek Driver http://www.realtek.com.tw/downloads/downloadsCheck.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

From the Audio Manager/Control Select the speaker tab. On the right hand side, there are six icons of connector Right click on pink connect icon. Select connection configuration. Select Rear Speaker Right click on black connect icon. Select connection configuration. Select Front Speaker Front Rear Sound will be switched

share|improve this answer

If you use ffdshow audio decoder for another programs, I found the easy way to expand. Just use custom matrix and choose 3/0/2 - 5channel -> custom matrix and write 1 to all rows and columns 1 only BackL BackR's. I use this watching tv on my dvb card software. Really works!

screenshot of mixer settings

share|improve this answer

Intro: I spent several hours over the last couple days trying to figure out why there is no sound coming from the REAR speakers when playing 2.1 sources and such (streaming videos or music from online). 5.1 sound works in video games and DVD/Bluray, etc. There was no SPEAKER FILL option in the most recent REALTEK drivers.

Quick rundown of my problem: 5.1 audio only worked for 5.1 output sources, not for everything.

Interesting details: CONTROL PANEL > HARDWARE AND SOUND > SOUND, click Speakers (typical output source.... where the sound comes from), then the Configure button.. By default, it's set to Stereo (I just built a new computer, so this is where I was sitting). Set it to 5.1 Surround and it WORKS.... for only one source (I would steam a channel on DI.fm and if I reopened that stream, it would revert back). If I reopen anything or change a sound setting, it'll completely stop or it'll revert back to stereo sound. VERY clear difference, as with stereo, the volume out the front and center speakers is way louder than on 5.1, even on the same volume setting (I was using 50%).

I would change it from 5.1, open a source, change it to Stereo, open a source. There was a clear difference, and as said before though, it only works for ONE source. Keep in mind, Windows has an audio driver that has the SPEAKER FILL option, but as you're all probably aware, it's garbage. VERY quiet!

SOLUTION: CONTROL PANEL > HARDWARE AND SOUND > SOUND, click Speakers, then the Properties button, click the Enhancements tab (by default, Immediate mode is selected.... I left it checked, default position). Scroll down to the bottom of the list and check DTS Connect. Apply.

You can even use the Room Correction enhancement to further produce a more desired volume from your speakers based on your configuration!

Fixed the issue. I can now restart my computer, play multiple sources, etc, without having to change anything in the sound options ever again!

MOTHERBOARD: Asus Maximus VI Hero w/onboard Realtek HD audio.

share|improve this answer

I had a different problem where speaker fill WAS working for all windows sources like iTunes, Media Player, Winamp, etc however Pandora via Chrome was not filling for some reason.

I found this solution: https://plus.google.com/+UweTrottmann/posts/NkJtxz7iHMP

  1. Go to chrome://plugins/
  2. Expand the "Details" [+] button
  3. Disable the flash plugin that is NOT installed in your windows directory
  4. Restart chrome and enjoy speaker fill from Pandora

enter image description here

share|improve this answer

The freeware audio player foobar2000 has an add-in that allows you to upmix to up to 18 channels called MatrixMixer.

MatrixMixer also has a more general package, but it appears to not have been updated in quite some time, so your mileage may vary.

share|improve this answer
    
There's a newer foobar plugin called Channel mixer which does the same –  nixda Dec 24 '13 at 4:31

If you are using a Creative sound card you can turn on the CMSS Technology. http://www.creative.com/soundblaster/technology/cmss-3d/

It claims to upmix stereo into 5.1 sound, and can be enabled in their creative audio control panel. Once I enabled it, I got output from all speakers for all my MP3s.

It disables itself automatically, if the input itself is 5.1.

share|improve this answer

If you have a creative audigy soundcard, in CMSS 3D/ CMSS Modes on audio console application see if you have "Stereo Surround" option available http://i.imgur.com/RoTTA6n.png(i have it on audigy support pack 4.0 drivers from daniel_K), this is better than those CMSS modes, in the way that it actually duplicates the channels on the rear speakers, instead of doing some funky stuff that the CMSS modes do, which i find doesn't sound too good, sound get distorted and is like, .. metallic.

The good thing of this it applies to all programs on windows. And real 5.1 sources aren't affected. The realtek "speaker fill" option i have found (at least on my motherboard) it doesn't sound too good, like the cmss modes, so i would prefer to do it manually on each application(or try other solutions like enhancements tab mentioned on other posts):

If you use media player classic (MPC is also included on CCCP and other codec packs) you can also edit the matrix in options, it's easy http://i.imgur.com/VuaoCG6.png , and doesn't affect 5 channel sources.

On foobar, on preferences/playback/dspmanager there is a "convert stereo to 4 channels", just activate it and it just works (i don't think it uses center speakertough , you may need to download a matrix dsp if you need that one).

share|improve this answer

THE cheapest solution (albeit most probably not the best one):

http://www.dealextreme.com/details.dx/sku.741~r.54077798

share|improve this answer
    
this will make the 5.1 audio source, become a 2.1 audio source. bad suggestion –  Magnetic_dud Feb 3 '10 at 21:12
    
This is merely a splitter for a standard stereo source. –  Andrew Scagnelli Feb 3 '10 at 22:15
    
Thinking out of the box is not a bad idea. –  andySF Jan 15 '13 at 16:44
    
Actually this could be used to upmix 2-channel source to 4-channel. Most probably amplifier will add those center/low-freq channels internally, still depends on amplifier. However, there should be more than just a link... –  Sampo Sarrala Dec 24 '13 at 2:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.