Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

But it's fine when I'm using firefox,

and in IE I can also open the page via 127.0.0.1

Anyone knows how to fix it for IE?

share|improve this question
3  
What error message do you get? What result did you expect? –  James Polley Jan 17 '10 at 9:03

4 Answers 4

You should add http:// before localhost:port for IE. Unlike other browsers, IE needs to know what protocol is being used.

share|improve this answer
    
Are you sure? I just tried typing only localhost and IE turned it to http://localhost/ .. –  Bibhas Jan 31 '12 at 19:06
1  
Good habit is to include the protocol first; however if it is just localhost and no actual port number, you can usually just do what you stated and type localhost without issue. If you need port numbers though, you should used the proper protocol format. –  zackrspv Feb 1 '12 at 0:58

Some things to try:

  • try adding the port to localhost: localhost:80 or localhost:8080

  • try checking proxy bypass settings for Internet Explorer (Tools -> Options), make sure it's set to proxy bypass for localhost

  • Check C:\windows\system32\config\etc\hosts and make sure the localhost entry is there

share|improve this answer
2  
Under Windows 7, hosts no longer contains an entry for localhost (this is mentioned in the comments). –  Richard Jan 17 '10 at 9:37
    
I tried all the above,but still not working. –  user11671 Jan 24 '10 at 15:20
    
localhost still works in Win7 for me, using the latest IE. –  ekaj Jan 31 '12 at 17:40

If your local host uses default port(i.e 80) then it will resolve . If it uses different port then you will have to specify the protocol.

share|improve this answer

In my case, it is because there some add-ons that always go to search engine when I browse to my localhost. So I just disable this add-ons in Tools > Manage Add-ons > Click Search Provider > Set Default to Bing,

and my problem is gone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.