Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Unibody MacBook hooked up to an external display. By default when I boot up, the system will go to dual-monitor mode. I want to use only the external display.

The Apple supplied solution to this problem is to close the lid of the laptop which puts the machine into sleep mode and then move the mouse around to wake it up again. Because the machine is being woken up with the lid closed, when the displays are detected the system finds only the external. After the system is functional again, you can open the lid if you want and the laptop screen will be non-functional until you either tell the system to detect displays from the system preferences or you turn off the external display.

Every time I want to use only the external display, I must reach my hand over to close the lid, wait for the machine to sleep, jigger the mouse, wait for the machine to wake up, and finally open the lid again because I don't want the machine to overheat. I feel that this is very stupid to have to do. Why is there no button or menu option that says "don't use this screen"? Is there any third-party software way to change the screen setup that does not involve physically closing the lid and playing a game of "are you sleeping" in order to switch such a simple software setting? We are in the 21st Century and honestly this is childish.

share|improve this question
    
Here here. For a company that sells primarily laptop computers, this OS limitation is infuriating. –  Tobias Cohen Jan 17 '10 at 11:59
2  
I've run my MacBook pro with an external monitor for 2 years - closed - and it will not overheat. Otherwise I agree, this is lame. –  Darren Newton Jan 17 '10 at 13:46

6 Answers 6

While I agree that this limitation of the OS is annoying, Mac laptops are designed to be usable while closed without encountering any heat issues.

share|improve this answer
1  
Hmm...I didn't actually know that they were made to be usable while closed. Though this presents another problem because if you close the lid you must own an external keyboard and mouse. In other words you cannot use an external display only and use your laptop's keyboard without the hassle. –  hekevintran Jan 17 '10 at 20:06
1  
Yeah, I agree, it's still an annoying limitation, although it's probably a pretty rare use-case for an external monitor while not using a KB/mouse. –  phoebus Jan 17 '10 at 21:31

You can also set the computer to use the external monitor as the primary monitor by plugging it in and then under arrangement in the display settings, drag the little white bar onto the external display. Once you have done this you can either ignore or make use of the laptop display as a secondary monitor, or if it bothers you turn down the backlight until it goes off.

OS X will remember that you want the external display to be the primary display, and all you have to do then is turn down/off the laptop display. Not automatic, but it is close and free.

The solution I offered earlier would be a more permanent solution.

share|improve this answer
2  
This is what I am doing now. It has two problems: 1) If I make the external display the right monitor, moving my mouse quickly to the right will cause the cursor to hit the edge. However this will not work on the left edge because that's where the laptop screen is. Not being able to hit the screen's edge reliably is really annoying if you use the corner's of the screen for Exposé. 2) The machine runs hotter because it must power two screens instead of one. –  hekevintran Jan 28 '10 at 0:17

I had the same issue. I'm just trying SwitchResX and I think it solves the problem. Running it for the first time though so I'm not sure yet.

share|improve this answer

I think the only easy solution is to just use mirrored mode, although that will limit the choices of resolutions you can use on the external.

share|improve this answer

I think your solution is going to include kernel modification. I don't know if you are up for the task, but you can try either booting without the following kernel extension:

/System/Library/Extensions/AppleOnboardDisplay.kext

Or finding a replacement for it from a source like those used by the hackintosh community.

I think I would try working without it at first...

Move the file to a ...kext.back, clear the kernel cache and reboot. If you have any trouble boot with verbose mode (-v) and have a look at the error codes.

share|improve this answer

I think you can start it up and as it is starting up close the lid and it will detect the external monitor as the primary.

share|improve this answer

protected by nhinkle Apr 18 '11 at 23:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.