Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been able to connect to my WinXP server's shared drives by using Finder's Command-K to browse the network. Unfortunately, when the server gets rebooted, the connection drops and sometimes I cannot get reconnected.

I have specified different protocols (afp / cifs / smb) and different login names (connect as...) with limited success. Once I find the right combination, I am good for a few weeks.

Once, it seems as though I had to unshared and shared the drive to get it to work. Unfortunately, it is very frustrating, so I try multiple things at one time, so when I finally get to the success point -- I honestly don't know what worked.

I followed Mac help, surfed for instructions, issues, etc., but nothing appears to be consistent. I would love for this thread to be the ultimate answer for all time!

Can anyone help me? If my description or question need more detail, please ask away!

share|improve this question

migrated from serverfault.com Jan 17 '10 at 8:45

This question came from our site for professional system and network administrators.

2  
Does your XP server always come back up with the same IP address? Have you tried connecting directly by IP using SMB? (ex: smb://192.168.0.5) –  Darren Newton Jan 17 '10 at 15:14
1  
When you are unable to connect what errors are you getting? -36, -50? –  Chealion Jan 17 '10 at 18:48

2 Answers 2

Hmmm ... there is often a client- and a server-side answer to such problems. I ran into to this problem again and I 'ejected' my USB drive, disconnected the cable and then plugged it back in. But the problem persisted. I even dropped and added the sharing permissions (that appeared to solve the problem the first time I experienced this -- may have been a coincidence and is not typically an option for the client-user).

This morning I decided to shutdown my Mac and when it came up, I went to Finder to look for the network drive and I got the login prompt. Now I am connected.

I tend to leave my Mac sleeping 7x24 when I am not using it so it is always 'hot' and ready to work. But I think that accumulates hidden problems and it deserves a good 'boot' every once in a while.

Problem solved (again) and in a different way.

share|improve this answer

Hardware problem! For some reason the USB drive is going silent. I was rebooting the server for other reasons and clearing up (masking) the problem. My connection is now staying up across Mac reboots, sleep/resume, etc.

Thanks for the help, suggestions, etc.

Sorry for the misdiagnosed problem.

BTW - Yes, I did try SMB as suggest by Darren, what I didn't do was look at the access light on the USB drive :((

Also, the error was that Finder, using the browse feature, would simply timeout and say 'not found.'

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.