Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Genex MP3 player and when I switch it to storage mode and connect it to my computer I see a popup message informing me that the USB hardware is unrecognized. How do I get my computer to recognise the device correctly?

share|improve this question
Do you know the product name of your mp3 player? – Gnoupi Jan 17 '10 at 11:08
Details would be appreciated. – alex Jan 17 '10 at 11:25
You're still basically asking "My car is broken, how can I fix it?" - we can give general help, but more information is probably needed. – Phoshi Jan 17 '10 at 14:22
What operating system as you using (i.e. Windows XP, Windows 7, Mac OS X, Ubuntu Linux)? – Matthew Pirocchi Jan 17 '10 at 15:42

Some players connect using a protocol called Media Transfer Protocol (MTP), which integrates well with Windows Media Player (WMP) and makes for simpler synchronisation with DRM'ed files, but it won't work without a recent version of WMP.

Others use mass storage device class (MSC), which loses some of MTP's DRM compatibility but allows you to access the files within Windows Explorer.

You may be able to switch your player between MTP and MSC, and I suspect you may have more success in MSC mode.

But again, it would help if you could post details of the player.

share|improve this answer

You will sometimes see error messages such as these, and sometimes no response at all if the device access mode is set incorrectly. Look for a setting on the MP3 player called mass storage mode (MSC) (or similar). This will make the MP3 player function as a USB drive.

share|improve this answer
Thanks, this helped me. I have Transcend T.sonic 330 8GB. It worked fine both on Windows XP and 7, but on old machine with XP it just couldn't be recognized. I went to settins->MTP and changed there to USB mode. After this it works fine on old machine. – geotavros Nov 8 '11 at 8:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.