Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Few days ago I've installed Linux Mint on my laptop and it runs great in dual boot with Windows 7 64.

But there are programs on Windows which started to crash after installing Linux! I have no idea why do them crash. They worked completely normal before installing Linux. The only changes I made in the system are reducing size of disk D: (a disk with neither Windows nor these programs) partition by 12 Gb and installing GRUB.

Programs that crash include:

  • Microsoft Visual Studio 2010 Beta2, crashes then launching, after splash screen. However, 2008 version works great.
  • TES4: Oblivion game, crashes then trying to continue a saved game
  • Crysis game, crashes then launching

Screenshot:

alt text

These are my partitions:

Windows 7 "Disk management" screenshot

I really want to get these programs working, especially VS2010. I don't want to delete Linux partitions or reinstall Windows 7. What can I do? I have no idea. Maybe it's a common problem with easy solution or I need to send emails to someone.

share|improve this question
    
I think you already, but ask for sure, did you try reinstalling the programs? –  phunehehe Jan 28 '10 at 17:49
    
yep, I reinstalled Crysis –  valya Feb 6 '10 at 8:16

6 Answers 6

up vote 0 down vote accepted
+50

The programs that you are having problems with are very new programs that probably have a very picky copy protection scheme. What I am thinking is that they may be looking at some info on the master boot record (MBR) of the disk for verification that they have not been moved to another disc or system. I have no proof of this and I would default to someone with more windows experience than me to verify my conjecture. I do propose this for a couple of reasons:

1: the MBR is the only sector of the disk "shared" by windows and linux 2: the MBR is modified by grub on its install

Maybe windows 7 is doing some kind of MD5 type hash of the boot record?

This is my guess. Looking for verification or debunking of this idea...

share|improve this answer
1  
Is very strange that big software developers (as microsoft) use an scheme that has as a rule that the MBR can not be modified. –  SoMoS Jan 28 '10 at 10:21
    
As a general rule there are always tradeoffs between utility and security. Using you car as an example, it would be very convenient to never lock it, but you might find your car missing one day! In MS's case they are understandably trying to make the system more secure, but that leads to hiccups like you are encountering. I am sure that the idea is to avoid having something inserted or modified in the MBR without your knowing about it. But because MS is closed source I can only speculate. –  gavaletz Jan 28 '10 at 13:03
    
answer was auto-selected –  valya Feb 6 '10 at 8:17

I don't know if this may help, but run this to check the integrity and fix errors with your system files in the Windows command line:

sfc /scannow

You could also try rinning the disk checker in Windows on your D: drive in case things went wrong when resizing:

chkdsk D: /F

Other than that I suggest you reinstall the programs that are giving your trouble.

share|improve this answer

I cant tell you 100% certain but I suspect the real issue is because you have exceeded the number of primary partitions allowed - which is 4.

Look at this article. Near the bottom there is info on setting Ubuntu to use a local file on the same partition as the install. I have done this and works well. This should also work for MINT.

I would configure MINT to not use a swap partition and instead use a swap file. Then delete the MINT swap partition. You probably can then expand C to use the freed space (I haven't tried that). In disk management whatever you do don't try to change the Linux partition types other than deleting the swap partition after changing your MINT setup.

share|improve this answer
    
hm, but other programs work completely normal. if you are right, it's odd. they probably would stop working too! –  valya Jan 17 '10 at 16:06
    
The 4 primary partition limit is important. Likely the behavior depends on how the application accesses the drive. See: pcguide.com/ref/hdd/file/structPartitions-c.html. –  jtreser Jan 18 '10 at 1:49
    
hm thanks. I'll try swap file! –  valya Jan 20 '10 at 0:41
    
I've deleted swap partition and extended my ext3 on its space. now I have only 4 partitions, but the problem is not solved :( –  valya Jan 21 '10 at 22:51
    
OK sorry but almost out of ideas - I assume problem is with VS and the game? Probably I would try reinstall VS first see if the problem stops. –  jtreser Jan 24 '10 at 12:41

Do you still have lots of free space on D? Is that your pagefile drive?

If your swap file was on D, it's possible you no longer have enough hard drive space for your page file. As a result large applications (VS, the games you mentioned) crash.

share|improve this answer
    
pagefile.sys is on C:. there are 12 Gb free. (is it the swap file?). There are 1.7 Gb free on D: but there is nothing needed for system, I think. –  valya Jan 17 '10 at 13:56
    
by the way, I've run out of space on D: earlier, before installing Linux. even with 400-500 free megabytes on D: there was no problems! –  valya Jan 17 '10 at 13:57
    
added another screenshot: dl.dropbox.com/u/96578/partitions.png to my post, maybe it can help. thanks –  valya Jan 17 '10 at 14:01

I think gavaletz's answer is the most likely to be correct, games can do some crazy things. Probably the best way to fix that would be to reinstall them.

With regards to the Visual Studio problem, it's a beta! It's supposed to crash ;)

share|improve this answer

Given your description, make sure there is no DRM/trusted computing component active and in use. I don't know how Windows 7 calls it (Secure Computing, etc etc) but you might have to disable it on the BIOS.

Post your answer or an update because I suspect you won't be the first one to note this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.