Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install a program on my Windows 7 machine and it says that I need to have .NET 2.0 or later installed. Since Windows 7 comes with .NET pre-installed, I called support and they told me to just re-install .NET since my .NET install is probably corrupted. The program I am trying to install is SNGWiz. I do not think its installer is borked.

However, when I install .NET 3.5 SP1 using the download from the Microsoft .NET web site, I get the following error:

You must use 'Turn Windows features on or off' in the Control Panel to install or configure Microsoft .NET Framework 3.5 SP1.

I have gone to the Windows Features on/off panel and have turned 3.5 both on and off and have tried to re-install .NET 3.5 SP1 under both situations. But it has failed with the same error.

What can I do?

share|improve this question
    
What's the program you are trying to install? Perhaps its installer is borked. –  Chris W. Rea Jan 17 '10 at 15:15
    
@BasicallyMoney I don't think the installer is borked. Program is www.sngwiz.com –  user1413 Jan 17 '10 at 15:41
    
@user1423 Any update on this issue? –  Troggy May 8 '10 at 20:15
    
No update troggy. –  user1413 Jun 6 '10 at 4:08
add comment

4 Answers

up vote 2 down vote accepted

no i am with the origional poster, even just switching it on doesnt help, try and update the .net framework with it on or off gives no difference, try to install the software after switching it on achieves nothing to, this is a major flaw in the system,

share|improve this answer
    
I agree with this. I tried a bunch of things and nothing worked. –  user1413 Aug 5 '10 at 2:38
add comment

No need to install. Just turn it "On".

The .NET Framework 3.5 is a built-in part of Windows in Windows 7. Turning the feature on is all that is necessary; the installers are built for previous versions of Windows.

share|improve this answer
    
That doesn't work. –  user1413 Apr 6 '10 at 11:16
add comment

Is .NET 4.0 already installed? This might be a problem for their installer?

The registry version key changed with 4.0, and depending how they check for .NET this might break their installer - it did for us, and the message you get is one that we saw too.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\<...>\<Version>
share|improve this answer
add comment

I see this:

it says that I need to have .NET 2.0 or later installed.

and this:

I install .NET 3.5 SP1

You should think of .Net 3.5 as more of a "plus pack" for .Net 2.0, as 3.5 still relies on the same core runtime from the earlier 2.0 release. Adding and removing 3.5 won't help you fix something broken with your 2.0 installation. To really be sure you have a good .Net installation, actually remove and reinstall .Net 2.0, not 3.5.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.