Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a speaker share application called SpeakerShare. What it does is simply share a server's speaker. When I am trying to connect to a server from a client, the server returns computer_name.local.. SpeakerShare finds server's ip by name, so it does not find correct IP address with .local. suffix.

How do I remove .local. suffix??

share|improve this question
add comment

2 Answers 2

Go to Control Panel > Network and Internet > Network Connections.

Right click on the network connection you want to change and go to Properties, Double click on Internet Protocol Version 4 (TCP /IPv4) and then click the Advanced Button.

Under the DNS Tab look for the various options and change to suit.

alt text

If you do not see any settings or anything obvious, this is most likely being set by your actual DNS server and you will have to change it there.

Lastly, you can also see if it is hard coded in the computer name. Open System Settings (easiest way is by pressing Windows Flag+Pause/Break, click Advanced system settings on the left and then go to the Computer Name Tab, and make sure that it isn't set to computer.local, you can check/change it here - click the Change Button, then the More button.

alt text

share|improve this answer
add comment

The ".local" suffix isn't necessarily provided by actual DNS (though it can be); it's often added as part of mDNS/Zeroconf, a service that helps computers on a local network discover each other's names and services in the absence of a real DNS server.

If you've installed iTunes, you've probably installed Apple's mDNS service called "Bonjour" (aka mDNSResponder.exe). You can stop and disable this service in Windows' normal service management application, or run these commands as Administrator:

sc stop “Bonjour Service”
sc delete “Bonjour Service”

If you haven't installed iTunes or have already disabled Bonjour, follow the directions in Wil's answer to check that Windows isn't adding the .local suffix automatically as part of its DNS settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.