Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to do some experimentation with hostap without disabling my primary wireless interface. How do I tell networkmanager to keep its hands off a specific interface or interfaces while allowing it to continue managing all other interfaces normally? I'm using Ubuntu 9.04.

(Wasn't sure if this should go on superuser or serverfault, as networkmanager isn't much of a 'server' tool - if it belongs on serverfault please feel free to move it)

Edit: I've tried adding this to /etc/network/interfaces:

allow-hotplug wlan2
iface wlan2 inet static
        address 192.168.49.1
        netmask 255.255.255.0

But this has no apparent effect, even after restarting NetworkManager.

Here's my /etc/NetworkManager/nm-system-settings.conf:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

Edit[2]: Looks like I needed to restart nm-system-settings, then NetworkManager.

share|improve this question
    
You don't have to put [Ubuntu] in the title. You could've made it 'Disabling network manager for a specific interface in Ubuntu', not to mention it's already tagged as 'ubuntu'. Just letting you know for future questions. –  Jorge Israel Peña Jul 21 '09 at 3:20
add comment

2 Answers

up vote 9 down vote accepted

To quote /usr/share/doc/network-manager/README.Debian:

Configuration of wireless and ethernet interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Only devices that are not listed in /etc/network/interfaces or which have been configured "auto" and "dhcp" (with no other options) are managed by NM.

This way you can setup a custom (static) configuration for a device and NM will not try to override this setting.

After modifying /etc/network/interfaces you have to restart NM with the command "/etc/init.d/network-manager restart".

and then it has some examples.

share|improve this answer
    
You can make the configuration either to the text files or via the network config gui. Either way results in NM not trying to manage the interface. –  pcapademic Jul 21 '09 at 19:39
    
Unfortunately it doesn't seem to work... see above –  bdonlan Jul 22 '09 at 0:47
    
... and solved it, see my second edit. Thanks. –  bdonlan Jul 22 '09 at 0:57
add comment

You can also add this line to /etc/network/interfaces

iface wlan0 inet manual
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.