Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Eee PC 701 4G, and some time ago I disabled its wireless NIC in the BIOS to save energy. Now I've come to need it working again, but I can't re-enable it, because it always goes back to being disabled after I boot the eeebuntu installed on the machine. If I just enable it in the BIOS, reboot and go into the BIOS setup again, it's still enabled, but if I let the OS load it'll get disabled. I'm really at a loss here, how do I find out what's wrong? Could it be Ubuntu that does this?

share|improve this question
add comment

5 Answers

Have you tried to reset the BIOS to factory defaults? There should be an option to reset it. Make sure you write down the current settings before you reset it.

After the reset, the wireless NIC maybe automatically activated. If not, try to activate it again after a complete reboot.

share|improve this answer
add comment

Do you have Boot Booster enabled in your BIOS?

https://help.ubuntu.com/community/EeePC/Using#Enabling%20Bootbooster

If so, try disabling it. This Eee-specific feature caches some BIOS info to a hidden disk partition, allowing you to skip parts of the boot sequence.

share|improve this answer
add comment

I would double check that you are saving the settings when you are exiting the BIOS.

Next, are you using Windows and did you install it yourself? If you disabled the wireless before installation, it is possible that Windows simply does not have the wireless drivers. I would recommend that you perform an update and try the physical/soft switch (I do not know on your laptop) to enable the Wireless.

(On my laptop, the BIOS reports the last used setting, so in Windows, if I use a hotkey FN+F1 to disable, it will show disabled in BIOS)

If you do not have success in any of these, I would suggest that you perform a BIOS update as this should also reset any settings in the process.

share|improve this answer
add comment

If you are running one the Linux variants and it has any sort of power management applications running check to make sure the wireless nic isn't disabled in there. I know on mine there is the eee-control applet which allows me to disable the nic and card reader.

share|improve this answer
add comment

On the eeebuntu forums, one user edited his /etc/init.d/eeepc-restore by commenting out the line with /etc/acpi/eeepc/eeepc-wifi-toggle.sh poweroff.

The reason given for this behavior is:

FCC regulations on powering a WIFI capable device in flight.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.