Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem with windows 7. My network connection used to work fine, then one day, all of the sudden it stopped wotking. I tryed everything possible to get it working (ipgonfig /renew, etc.), and after a while found that what helped, was to simply first disable, and then enable my network adapter from device manager.

Now the problem is that every time i restart my computer it stops working again and i have to do the same routine every time, which is starting to get bit anoying. I also tryed installing newest network drivers, but that didn't change anything. The adapter is NVIDIA nForce 10/100 Mbps Ethernet.

share|improve this question
    
Possible duplicate - superuser.com/questions/77804/… –  ChrisF Jan 18 '10 at 16:36
add comment

4 Answers 4

my experience with this prblem is windows update. IF i for some reason update the drivers for my realtek card it will not work. and the only way for ME to fix the problem was to roll a earlyer version of my win7.

share|improve this answer
1  
I have had this same issue recently with windows update - a realtek driver was applied in windows update that caused erratic behavior. You can check the update history to see if that was the case then roll back the driver. –  jtreser Feb 22 '10 at 11:14
    
ahh... that i actually did not know. thank you for the tip –  Tormod Feb 22 '10 at 14:28
add comment

Re-enabling the network adapter causes it to renew its connection to the router.

If you do have a router, I would have a look at its lease-time setting. It might be set to give your computer a very short lease on the connection. The default lease-time is normally at least 24 hours.

If you need more help, please supply more info about your network architecture and internet connection.

share|improve this answer
add comment

are you using windows update? Sometimes windows update renews your Network-adapter driver. Try to set back the old driver in the devices manager.

share|improve this answer
add comment

Rolling back the driver for the NIC should solve your problem.

share|improve this answer
    
What leads you to believe it is the drivers? Can you provide documentation about his drivers that suggest a problem with the version he is on? –  MaQleod Jul 14 '12 at 7:20
    
@MaQleod: You never know if you don't try... –  Tom Wijsman Jul 14 '12 at 15:31
    
@Tom: I agree, and there is no harm in suggesting it as a comment, but an answer should have some sort of documentation or explanation backing it up. Even an explanation as to why rolling back the drivers might help would be sufficient. –  MaQleod Jul 14 '12 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.