Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had installed XAMP a long time ago in my PC (Windows XP) but just yesterday when I tried accessing localhost, the page kept on loading and loading but giving no results. If I try to kill the process the page stops loading and informs me that it cannot locate the page.

share|improve this question

migrated from stackoverflow.com Jan 18 '10 at 18:52

This question came from our site for professional and enthusiast programmers.

4 Answers 4

try to run xampp-portcheck.exe it's located in the xammp folder check if port 80 is opened and used by xamp.

Have you installed skype? Skype and xamp has port problems

share|improve this answer
    
Skype will bind to port 80 by default. Turning off skype is a good idea if you need to run a webserver. –  futureelite7 Jan 18 '10 at 7:42
    
i dont have skype with me and port 80(HTTP) and 443(HTTPS) runs with apache, –  fallen_GURU_DOG Jan 18 '10 at 7:47

Is it running any kind of server-side code? It may be stuck in an infinite loop, or processing a lot of data. Does it eventually time out or give out-of-memory errors? These would be clues worth knowing about. Are you sure you're accessing the correct port? Are PHP, Apache and MySQL configured correctly?

Longer-shot: I've noticed some problems with the Keep-Alive header in some cases where pages would seem to load "forever" until refreshed. Killing this header has resolved a lot of things for me.

I'm sure others will have more insight into XAMP specifically, with which I have no experience.

share|improve this answer
    
nop... whenever i start the server so that it can show the xamp main screen it refuses. their is no code running –  fallen_GURU_DOG Jan 18 '10 at 7:29

Are you running the XAMPP control panel? Does it say that Apache is running?

Here is link to the XAMPP windows FAQ item for Apache not starting http://www.apachefriends.org/en/faq-xampp-windows.html#nostart.

The Skype conflict was what bit me in getting Apache to run. Easily fixed though . . . Go in Skype to Actions --> Options --> Connection --> remove the check mark at "use port 80 for an alternate port" and restart Skype

share|improve this answer
    
apache is runnig as per the control –  fallen_GURU_DOG Jan 18 '10 at 7:43
    
idont think if it is skype, cause i havnt installed it yet –  fallen_GURU_DOG Jan 18 '10 at 7:50

While giving telnet command for localhost & local IP 80 port not working and connection failed in client PC. In the same pc I am able to connect outside server ( where our system's application server Orcale 11g is located) with telnt 80 port.

To reach the outside server I have to go through local IP. since the local IP is not connecting to the port 80 in telnet I am not able to access the server. but the same local IP works in other client PCs. I hope this is a local client issue.

Kindly guide what kind of components to be invoked to access port 80 in local client PC? what are all the Firewall, windows components settings & services is required?This client PC recovered recently from Crash & factory default settings was restored . The O/S is Vista. Before the system crash everything was fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.