Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My settings:

~/.gnupg $ gpg --edit-key 92432433
gpg (GnuPG) 1.4.9; Copyright (C) 2008 Free Software Foundation, Inc.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Secret key is available.

pub  1024D/8----  created: 2010-01-02  expires: 2011-01-02  usage: SC  
                     trust: ultimate      validity: ultimate
sub  2048g/0-----  created: 2010-01-02  expires: 2011-01-02  usage: E   
[ultimate] (1). Hello <Testing>

I get this in Evolution:

Because "gpg: masi@gmail.com: skipped: public key not found
gpg: [stdin]: encryption failed: public key not found
", you may need to select different mail options.

Running the following does not help:

ps aux |grep gpg
# choosing the process id and killing gpg --daemon
kill <process_id>
eval `gpg --daemon`
# restarting Evolution and getting the same error with 
# Security settings without ticks at the four option boxes
# and havinsg my correct key-id in the box: I do remember my password
share|improve this question

migrated to stackoverflow.com by Masi, Ivo Flipse Jan 20 '10 at 12:53

This question belongs on our site for professional and enthusiast programmers.

1  
This is not programming related. Whoever moved this was incorrect. –  Broam Jul 2 '10 at 16:00

2 Answers 2

up vote 4 down vote accepted

Are you trying to send encrypted mail to yourself ? If not, generating a key for yourself is not sufficient, you need to import the public key of the recipient too.

In your gpg dump, it shows "Hello" < Testing > as your primary identity. The e-mail field is being used by gpg to get the keys of the recipients, so if you put bogus values in there it won't be able to use it automatically.

share|improve this answer

For others: If you're using Ubuntu, check the "Passwords and Encryption Keys" application (seahorse I believe; installed by default and shows up in Accessories menu)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.