Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have windows 7(64) installation setup on a Boot Camp partition on my MacBook Pro 13". I also access this partition through VMware hosted by OS X (snow leopard).

Every time I switch between VMware and Boot Camp windows says that it needs to be re-activated because of hardware or driver changes.

I've tried wmware KB KB 1003426 to no avail. Edo

Thanks,

Jason

Edit,

I am using the most recent VMware and tools.

I've tried "KB 1004917" as well. No Dice.

I'm considering re-installing at this point.

share|improve this question
    
Are you using the latest version of VMware Fusion with the latest VMware tools? –  fideli Jan 19 '10 at 2:18
    
What about this kb article? kb.vmware.com/selfservice/microsites/… –  David Kolar Jan 19 '10 at 17:39
    
Thanks for the suggestions, I actually tried 1004917 quite a while ago with the 2.5(?) version of VMware. Tried again though and it still won't work. :) –  Jason Hernandez Jan 19 '10 at 22:27

2 Answers 2

I fixed this by changing the virtual machine to use two virtual processors, which matches the actual machine.

It seems that 1 vs 2 processors was enough to trip windows activation.

share|improve this answer
    
Also try changing the MAC address of the virtual network adapter to match your physical MAC address. –  stephenwade Jan 14 '13 at 17:52

If you ring microsoft and advise them of your configuration they will provide you with another activation key for the unactivated setup either boot camp or through vmware.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.