Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed a new MSI 790GX-G65 and my Windows XP freezes a few seconds after it comes out of any sleep mode (S1, S3 or S4). My mobo has BIOS 1.4; it looks like there was a 1.5 version, a 1.6, and then they jumped to 4.0 (I wonder why?).

I wanted to update the BIOS to current. The MSI website offers a LiveUpdate Online service, which detects my BIOS version correctly at 1.4 and offers to upgrade it to 4.0. The process downloads the update and runs an installer program to do the update; however when it's supposed to actually do the update, a DOS command window just flashes up for about a 1/2 second and disappears with no text visible. Nothing else happens.

When I downloaded the BIOS update package, the instructions have a warning to use LiveUpdate when updating from 1.xx to 4.xx. I booted FreeDOS from Ultimate Boot CD and tried it anyway, but the updater just hangs the system with no output (I left it there for 20 minutes just to be sure it wasn't doing a slow silent update). Upon reboot all was OK, but no update was done. (I am used to Windows-based flashers with my older mobo's which also allow you to save the old BIOS to a backup first, and were very simple to use).

Anyone else encountered this with updating an MSI board? Any suggestions?

PS: This is an AMI BIOS.

PPS: I tried the M-Flash menu in BIOS; it let me backup the current BIOS to a flash drive, saving it as M7576AMS.140. But when I put the downloaded 4.0 image on the same drive, with the same filename format (M7576AMS.400), the M-Flash option to update the BIOS does not seem to see the Version 4 file.

PPPS: Solution posted as a self-answer below.

share|improve this question
    
Maybe is there an option at the BIOS to do the update right from there? Asus uses to have it. –  SoMoS Jan 19 '10 at 7:34
    
@SoMoS: Now that you mention it, there is an M-Flash menu (or some such)... I am just nervous about the repeated warnings to use LiveUpdate to do the 1.xx to 4.xx update. –  Lawrence Dol Jan 19 '10 at 7:55
add comment

1 Answer 1

up vote 1 down vote accepted

I have resolved this, but nearly gave myself a minor coronary in the process. Here's what I did (do the same at your own risk, YMMV):

  1. I formatted an old (64MB) Flash Drive with FAT-32.
  2. I used the BIOS M-Flash to save a copy of the current BIOS to the flash drive (very cool).
  3. I downloaded the 4.0 BIOS image from MSI's web site (the image is a file named M7576AMS.400).
  4. I copied the BIOS image to my flash drive as M7576AMS.400. But when I booted, M-Flash could not see the file.
  5. On a hunch, I copied the BIOS image to my flash drive as M7576AMS.160 and M-Flash now showed the file (in the BIOS update function).
  6. I updated with the (phony) 1.6 BIOS that was actually 4.0.
  7. [tense few minutes while we update and reboot after playing funny buggers with our brand new computer that we need functioning in order to work from home tomorrow - I never said I was being smart about this].
  8. I crapped myself when the computer beeped numerous times during BIOS check and then finally said something like "Your mainboard is damaged, rebooting to reload BIOS from USB". When the bios loaded it showed only the M-Flash option. All other BIOS settings were suppressed.
  9. I took the update option again, expecting to be able to restore the 1.4 version image I had so prudently created before attempting to update. To my great dismay it showed only the 4.0 file.
  10. I figured I had just 2 options (a) run upstairs to the laptop, rename the 1.4 image to xxx.400 and use that to reflash the BIOS and try and fool the computer one more time, or (b) return to the store, MB in hand, hanging my head in shame and meekly try to cash in on the inexpensive 1 year replacement warranty I had purchased.
  11. However, being the veteran computer programmer I am, I chose hidden option, (c) try flashing the same image again although all reason dictates the outcome can be no different. Which I promptly did, figuring I had little to loose.

Imagine my complete surprise when I was rewarded with the expected BIOS checksum failure and was subsequently presented with the full BIOS config menu intact, was able to reconfigure everything and finally boot into Windows normally with a functioning system.

There was a perceivable different between the two flashings: On the first run it wrote the update in fits and starts, anywhere from 2% to 8% at a time, with varying pauses, while the second time through it smoothly reported 3%, 6%, 10%, ... 93%, 96%, 100% at regular intervals.

Oh, and after all that, the computer still does not resume from S3 sleep (I didn't try S1 or S4 because I need some myself right now... sleep that is).

Hope this is of benefit to someone else with an MSI mobo.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.