Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I display line feeds and/or carriage-return characters in vi/vim?

I know that set list shows all the whitespace characters (?), it also replaces tabs \t etc (but that's not what I want). Basically I just want to display certain characters like \r (on Debian this seems to be the default, however on Gentoo it's different).

Kind regards

share|improve this question
add comment

3 Answers

up vote 11 down vote accepted

In recent versions of Vim there's a 'listchars' setting that lets you specify which characters should be used for the EOL and TAB characters, and for trailing spaces.

You could:

set listchars=eol:$,tab:\[SPACE]\[SPACE]

...to display eol chars specially without collapsing tabs (type a space character, not [,S,P,A,...).

I don't know of anything specifically about return chars in the 'listchars' setting, but I suspect you can use syntax highlighting for this. I think the default display of \r characters is to show them with SpecialKey highlighting.

So the default SpecialKey highlighting of \r characters, combined with setting 'listchars' as above, should be close to what you need.

:highlight SpecialKey ctermfg=5

...if you're fond of magenta.

share|improve this answer
    
Thanks, listchars already helped. Would you mind to explain me how to use SpecialKey? I can't find any useful information, vimdoc.sourceforge.net/htmldoc/syntax.html#hl-SpecialKey didn't help much either. –  watain Jan 19 '10 at 11:38
    
SpecialKey is the built-in syntax-highlighting label for any characters which are displayed "specially": control chars and the like. If you type ":highlight SpecialKey", that'll tell you how those characters will be displayed. –  njd Feb 9 '10 at 10:21
add comment

reopen DOS-formated text file in UNIX formart:

:e ++ff=unix

you will see ^M(\r) at the end of line.
if you want display ^M in hex:

:set dy=uhex
share|improve this answer
add comment

Add the following line to your .vimrc file:

set fileformats=unix

This causes vim to support only unix-style files natively. For non-Unix style line-endings, the carriage return character \r will be displayed explicitly in vim as ^M.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.