Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Control Panel\Network and Sharing Center, I have two networks listed (I have three network adapters). One is my internet connection, and is described:

  • Inet (Private network)
    • Access
      • Local and Internet
    • Connection
      • Inet Wireless (Inet)

This correctly corresponds to the SSID of the Internet router.

The other two adapters are described like this:

  • Unidentified network (Public network)
    • Access
      • Local Only
    • Connections
      • Gigabit Wired
      • Internal Wireless

The problem is that this machine is running a backup task and I'm trying to restrict the task so that it only starts if a specific network connection is available, in particular, the one connected to the adapter I've named 'Gigabit Wired'. But this network doesn't have a name (it's only "Unidentified network"), and the name doesn't distinguish between the adapters (which have different IP subnets - this machine acts like a router).

Re the backup task and network presence: in a Task Scheduler's Task properties, the Conditions tab has an option: "Start only if the following network connection is available". However, I can't get my Gigabit Wired adapter to show up as a network in the dropdown here.

So, how can I name my network connections / subnets / adapters appropriately to wire up with scheduled task conditions?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Note, I did this is on Windows 7, but I believe it should be very similar for Vista/Server 2008:

  1. Open the Network and Sharing Center
  2. Click on the icon representing the network you want to rename
  3. Type the new name in the dialog that appears and click Ok
  4. Create a new task in the task scheduler, it should now show the updated name
share|improve this answer
    
Hm. The icons at the top - these just start Explorer or the web browser depending on the nature of the network. The icons corresponding to the network in the list, these don't do anything. The "Customize" link at the rightmost lets me toggle Public/Private network, but no names. –  Barry Kelly Jul 21 '09 at 6:47
    
Make sure you click on the icon for the network under "View your active Networks" –  heavyd Jul 21 '09 at 10:34
    
I also noticed I couldn't change any of the "Unidentified Networks'" names, so you may need to put them into Home or Work groups first. Here is a script to do that: blogs.msdn.com/dimeby8/archive/2009/06/10/… –  heavyd Jul 21 '09 at 11:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.