Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Outlook 2007 connected to Exchange 2007. When I initially configured it, it asked for my password the first time. From then on, it remembered the password.

Recently, our AD policy required that I change my password. Now Outlook always asks for a password to connect to autodiscover.mydomain.com.

I enter the password, and click "Save password" but it always asks again. I suspect that it has cached the orginal password somewhere, but I can't find it.

Any ideas?

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Does the problem persist with a fresh profile, configured with the new credentials?

You may also have an incorrect password saved in your saved passwords. You can manage your stored passwords from Control Panel -> User Accounts. (I believe the process is slightly different under XP and Vista)

share|improve this answer
    
Yes, I tried removing the Exchange Connection, and re-doing the config. Your second point may be the clue, I did have some entries related to mail servers in my Saved Passwords. That was pat of the method for solving the HTTP/RPC password issue Bruce McCleod mentioned in his answer. I don't use HTTP/RPC on this network, but I tried setting the passwords when I first started troubleshooting this. I'll delete the stored passwords, and see if it fixes it. I will let you know. –  BillN Jul 21 '09 at 13:43
    
Removing the enteries under Control Panel, User Accounts, Advanced, Saved passwords that related to mail servers. I had several, autodiscover.MYDOMAIN.com, owa.MYDOMAIN.com, and also entries for the Exhange edge servers. I shutdown Outlook, deleted all of them, and restarted Outlook, no prompt. I rebooted the laptop, and still no prompt. YEAH! –  BillN Jul 21 '09 at 15:10
    
Awesome! Glad I could help! –  EvilChookie Jul 21 '09 at 18:37
    
This sounds like the exact same issue I'm having on XP w/Outlook 2007. Inside the XP control panel > users > ... I can't see anyway to see/modify passwords though... any ideas? –  scunliffe Feb 22 '10 at 14:37

Depending you how exchange is installed and configured, your exchange server might have a front end, and a back end. This setup is typical if you are accessing via HTTP over RCP, in an internet environment.

In those situations, saving the password only saves it for the front end, not the back as that is a different machine address and that is why you still get prompted.

Oh and there might be a server issue as well, if you are interested this http://serverfault.com/questions/42902/outlook-2003-is-prompting-my-active-directory-users-for-their-logon-credentials-w question on serverfault may be of interest.

Edit:

You might want to check or see if you can add or need to remove cached credentials in control panel > accounts > credential manager

share|improve this answer
    
I've had this happen on a different network where we where using HTTP/RPC. However we are not using HTTP/RPC, only straight TCPIP, and VPN if we are off the network. –  BillN Jul 21 '09 at 13:34
    
If you connect directly to Exchange this is not relevant. BTW it's covered here: serverfault.com/questions/39537/… –  splattne Jul 21 '09 at 13:49

This may be a Windows security issue. If your (old) password is stored somewhere else (maybe a Windows Service running under your account or a connected network share on another machine) where an automated login is configured, after a certain treshold of failed login attempts, the server asks for password every time on other automated logins. So, this will affect your Outlook login, even if the password you insert for the login is the right one.

This behavior is known - probably not in your case - wenn a virus attemps to crack password sending login requests to your server, like the Confickr worm does.

share|improve this answer
    
This is possible. I know there are no services running under my profile on this machine or elsewhere on the network, but a network share is possible. You login to a machine to troubleshoot it, need a drive mapped to a tool, and forget to uncheck the reconnect box, it happens. Any pointer on how to find them? –  BillN Jul 21 '09 at 13:46
    
You could check the server's event log. –  splattne Jul 21 '09 at 14:43
    
Yes, but you'd have to know which server to check. –  BillN Jul 21 '09 at 15:07
    
Your domain server should show some authenication failures. –  splattne Jul 21 '09 at 19:25

Are you sure the password is correct? Even if you click "Save password", if the password is incorrect, it will still prompt you for the correct password (even thought it does not tell you the previous password was incorrect.)

share|improve this answer
    
I encountered this exact problem not too long ago..i had changed password just before my vacation due to expiration, and i hadn't updated this for Outlook...ended up with a whole day of frustration of not understanding why my password wasn't working... :D –  pavsaund Jul 21 '09 at 10:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.