Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My experience with TFS is limited. We run Team Foundation Server off a build server I will denote as 'Alice.' Alice has been working great until we ugraded to VS 2010; and with the urgency of a build coming up in the next few weeks, my question is how do we get a successful build? I followed the instructions listed here: http://richardsbraindump.blogspot.com/2009/11/how-to-build-vs2010-solutions-using.html, however the build fails. My pathway towards the solution: had me put VS 2010 on Alice, instead of turning off the build service and turning it back on, I simply restarted the server*, modified a pathway as it was listed (previously "" and Norton Ghost 2003 gave me a problem with that in the beginning).

*denotes possible problem

What happens: CI_X.1 - Failed - Any help (including something as simple as analyzing the summary to someone's own experience with the same environment would be much appreciated)

Update (Error found): C:\Program Files\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(373,7): error MSB4131: The "Reason" parameter is not supported by the "GetBuildProperties" task. Verify the parameter exists on the task, and it is a gettable public instance property.

share|improve this question
    
To even remotely try and assit a lot more details are required. You have a lot of background, but what exactly is the error, where does it fail, does the build server start up? Be specific, and with details on what you've already done. Please note, VS 2010 B2 should NOT be used to deploy production applications, even with the Go Live license. The license only means that you can upgrade from B2 to RTM. –  Diago Jan 19 '10 at 21:07
    
I was mistaken about the actual release the lead programmer wants a new build for documentation and testing purposes, thanks for the note. To be precise it fails at: Using "DeleteWorkspaceTask" task from assembly "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\Microsoft.TeamFoundation.Build.Tasks.VersionCo‌​ntrol.dll". Task "DeleteWorkspaceTask" DeleteWorkspaceTask TeamFoundationServerUrl="dev-svr:8080/"; BuildUri="vstfs:///Build/Build/1679" Name="ALICE_3_" DeleteLocalItems=True TF14061: The workspace ALICE_3_;SCIENCE\TFSservice does not exist. –  Matt Jan 21 '10 at 15:02
add comment

1 Answer 1

According to this MSDN article there is no reason property on the GetBuildProperties task. It is extremely likely that this is a new undocumented property, however not very likely.

The problem could be in the project file itself however the Build Server is not able to process the exact error. The .targets file is part of TFS 2010 and referenced by MSBuild to compile the project, and this could very well be a bug. I am not near my TFS 2010 server, however have not seen this error come up with any of the projects currently running through the build server.

I suggest you file a bug report at Microsoft Connect. They generally respond within 48 hours. Also search to see if this is not listed there already. I did a brief search and couldn't find anything as yet.

From Seeb's answer on the MSDN forums however a suggestion is to edit the targets file directly to workaround this error:

  • I opened to the directory C:\Program Files\MSBuild\Microsoft\VisualStudio\TeamBuild\
  • I made a copy of the file Microsoft.TeamFoundation.Build.targets
  • I deleted into the original file the line which caused the problem (search the word "Reason")
  • And finally, I saved the original file

The new queued build was a success.

share|improve this answer
    
This worked for me. Commenting out the reason line solved the issue. –  Paul Sep 10 '10 at 19:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.