Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have XUbuntu 9.10 installed on a Toshiba NB200 netbook with Intel video card that's handled with i915 driver.

With 2.6.31 stable, recommended kernel everything but WiFi works fine: Atheros ath9k WiFi shows too small signal power and loses packets in 'bursts' sometimes.

With 2.6.32-* (I tested -9 to -11 from Ubuntu's kernel unstable ppa) everything works fine just prior to first suspend: echo mem >/sys/power/state. After it random unidentified fullscreen 'one-frame' flickering begins in Xorg, and after a couple of minutes everything eventually hangs while showing filled grey (not white; it is like default button colour) screen; no X keys are working: Ctrl+Alt+Fn don't, blind typing in console too. Magic SysRq still works and I was able to reboot.

Also there is one out-of-tree kernel module called omnibook that is required to turn on WiFi and Bluetooth.

Any advices?

share|improve this question

migrated from stackoverflow.com Jan 19 '10 at 22:15

This question came from our site for professional and enthusiast programmers.

    
Someone said that KMS (kernel mode setting) may be involved. Is that true? – whitequark Jan 20 '10 at 18:16
    
After full upgrade to lucid everything is the same. – whitequark Jan 21 '10 at 9:46

First: You should try a vanilla kernel from kernel.org. Here you can find a VERY good howto!. Second, i915 is being worked on. Intel just dropped UMS totally (the opposite of KMS, the one which were used recently.). If I remember clearly, some update arrived into the 2.6.33. If the first method wont work, just try to use madwifi with the 2.6.31. I tried, and I had a success with it. (Do a google search and you'll find many good docs how to blacklist current ath9k and use madwifi.)

share|improve this answer
    
Thanks, the howto is very good, will try it now. One question about madwifi: does it support connecting in both the monitor and infrastructure mode (ath9k does)? That's important for me. – whitequark Jan 24 '10 at 11:00
    
The wiki page says so. madwifi-project.org/wiki/About/MadWifi . I had to change to madwifi cuz' I wanted to share my internet connection and ath9k didnt work like I wanted to. – Shiki Jan 25 '10 at 12:17
up vote 0 down vote accepted

So after Xorg upgrade the problem disappeared, and even 2.6.32-11 kernel works now. Hope this would help someone.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .