Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having an odd problem that probably has a simple solution that I'm missing. I switched our wireless router to different DNS servers (google's public DNS in lieu of our ISPs). In the router settings, this involved unchecking the "automatic from ISP" checkbox. I've verified that those changes persisted correctly on the router config screen.

However, on both the laptop (win7 ultimate, x64) and my desktop (vista ultimate, x64), if I do an ipconfig/all, all 4 servers are listed: my ISPs DNS servers and google's public DNS servers (in that order). I.e., the output (just the DNS info) is pasted below (note the 8.8.8.x is google's public DNS IPs). I've tried doing an ipconfig/flushdns and some other steps, as well as rebooting.

The problem remains: I can't seem to get rid of the extranous 209.18.47.x DNS IPs.

Ideas, anyone?

DNS Servers . . . . . . . . . . . : 209.18.47.61
                                    209.18.47.62
                                    8.8.8.8
                                    8.8.4.4
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

ipconfig /flushdns does not do what you think it does. If your computer is not retrieving these values from DHCP:

  1. Start -> Run -> ncpa.cpl
  2. Find your adapter, right click and do "Properties"
  3. Find TCP/IP and do "Properties"
  4. Click "Advanced" and then "DNS"
  5. Remove the DNS entries there

If your computer is retrieving your DNS servers from DHCP you have configured the router incorrectly. You may want to switch to static DNS servers (repeat step 1 to 3 and put the DNS servers into the corresponding window).

share|improve this answer
1  
You keep using that command. I do not think it means what you think it means. –  Stephen Jennings Jan 20 '10 at 2:12
    
@Stephen Jennings: classic... ;) –  mpeterson Jan 20 '10 at 2:28
    
Good sugs. Seems to be a Windows characteristic (not necessarily a "bug" per se). For now, I went ahead & hard-coded the DNS IPs & that works fine. –  Garrett Jan 21 '10 at 2:47
add comment

I have tried a few things and am unable to replicate this behaviour.

First thing is just to make sure they are not hard coded in your network card, however, I tried manually editing mine and it simply overwrites DHCP entries, not add them in addition to.

My guess this is down to a bug/problem in your router.

If you have the option, try to change from DHCP to hard coded entries for your ISP's ip settings. This will work as long as you are on 24/7 and generally maintain the same ip. If your ip changes regularly, this may not work.

Lastly, if you are getting no where, you may want to just go into network settings for the card and simply put 8.8.8.8 and 8.8.4.4 as your adapters only dns settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.