Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just manually installed the Apache HTTPD 2.2.14 server in Ubuntu following these instructions (and using all default options). Since I did the manual installation, once I tried installing passenger module for Apache (through passenger-install-apache2-module), it found everything it needed, except for Apache. The error message is as follows (I installed everything else through synaptic, so those have no problems):

  • GNU C++ compiler... found at /usr/bin/g++
  • Ruby development headers... found
  • OpenSSL support for Ruby... found
  • RubyGems... found
  • Rake... found at /usr/bin/rake
  • rack... found
  • Apache 2... not found
  • Apache 2 development headers... found at /usr/bin/apxs2
  • Apache Portable Runtime (APR) development headers... found at /usr/bin/apr-1-config
  • Apache Portable Runtime Utility (APU) development headers... found at /usr/bin/apu-1-config

How can I make the passenger module installer (or anything for that matter) detect the Apache server installation?

share|improve this question
add comment

3 Answers

It mostly depends on the packages involved, and where they are installed. If you installed one package outside of the package manager, you might need to install other packages outside the package manager. Some packages allow you to specify the locations of their dependencies at compile time (via flags to their configure scripts).

If you installed Apache to the default location, it's probably in /usr/local. Is /usr/local/bin in your PATH? Try adding it before you run the passenger install script.

If you really need Apache2 2.2.14 instead of 2.2.12 (as is available in the Karmic repositories), consider downloading the newer version's source package from the Lucid repository and building your own packages for Karmic (or whichever Ubuntu version you're using). That gives you the advantage of using the system package manager, and the passenger installer shouldn't have any more difficulty.

share|improve this answer
add comment

Often, a configure script will have options like --with-apache2=/usr/local/apache2 or something. --prefix=/usr/local is also a possibility. Try running ./configure --help from the source directory of passenger to see if these options are available.

share|improve this answer
add comment

I had the same sort of problem. Check whether there's an option telling you whether you want to cancel or continue (pressing Enter).

Press Enter and the installer will give you the installation commands (apt-get install, etc) for the missing packages. That worked for me and so far I haven't got any problem.

Check out Phusion Passenger users guide for further information.

share|improve this answer
1  
Super User is not a discussion forum. If you have a comment, please use the "add comment" button once you have enough reputation. –  Hello71 Jul 13 '10 at 1:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.