Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The WD-My Book 500GB is recognized as a local disc in my system(Windows 7), but it's drivers fail to install successfully when connected via USB cable with computer. Then when I try to open it(explore), it slows down the PC, and after some minutes it displayes the message: 'F:\ is not accessible'. And after some time it shows another message asking me to format it. I really do have important data I wanna get from it, so I can't format it.

Till now I have tried the following, none of them succeed: - using a scanning\fixing thing from Hiren CD, - accessing from a suse(Linux)live CD, - accessing the hard drive from safe mode of my PC, - tried on a PC running Vista OS, - googled for a solution, nothing relevant found, just stories, no solution

Is there any fix for it? Somewhere I can get the drivers?

Any way that does not include formatting it, is highly appreciated. The fact that Windows recognizes the drive as Local Disk, isn't this a sign that the drive is not dead?

share|improve this question

3 Answers 3

up vote 4 down vote accepted

TFM's right. Specifically, here are your troubleshooting steps:

  1. Remove any extension cables and use a short, known-good USB cable.
  2. Try it in every USB port on the machine.
  3. Try on another computer, in every USB port.
  4. Try with a Linux LiveCD.
  5. Open the USB enclosure case, disconnect the drive, and connect it internally to a testbed PC (or one that you can use as such). I recommend booting the testbed PC with a Linux LiveCD to check the harddrive.

Try to do any mounts or filesystem checks in a read-only mode first.

Step 5 will void your warranty, but at this point warranty service will only get you a working drive; it will not recover your data. If your data is that important, voiding the warranty isn't a real concern.

  • If step 5 shows the drive is good -- that is, it is recognized by the testbed BIOS, and the Linux LiveCD can read and mount the partition -- then you've got a dead enclosure.

    You can probably stick the drive in any new USB enclosure and have a working external drive again; alternately, you can back up the data to another drive, verify the backup, and return the drive+enclosure to Western Digital for warranty service (hey, they might not go for it, but it won't hurt to ask).

  • If the testbed BIOS can't recognize the drive, you've got a dead drive -- take it to a professional and prepare yourself for a large bill.

share|improve this answer
    
the Linux Live CD did not give any results, it shows the drive as mounted and when trying to explore it, it frezees the system, then nothing works anymore, i should force a shutdown of the pc. I'll try the fifth step, I really hope it can solve the problem, if the drive isn't dead :(((( –  kipsitdown Jan 20 '10 at 13:16
    
the fact that windows recognizes the drive as Local Disk, isn't this a sign that the drive is not dead? –  kipsitdown Jan 20 '10 at 13:39
    
It's probably not completely dead, but my guess it has some bad sectors. Can you try using ddrescue to read the data off the drive? You will need another 500GB+ disk to write the data too. ddrescue makes a mirror of the drive (like dd) but handles reading around errors. It may be on your live CD or download System Rescue CD –  shf301 Jan 20 '10 at 13:56
    
thnx :), finally smth to hope again. I'll try this too –  kipsitdown Jan 20 '10 at 13:58
    
@kipsitdown: i concur, that's a good sign it isn't completely dead. i expect you'll get better results pulling the drive from the enclosure (and connecting it to a PC internally), but as long as you're careful you can try it first on the USB interface and pull the drive later if it's not working over USB. –  quack quixote Jan 20 '10 at 14:08

There's obviously a hardware problem. Either the cable, or the hard drive is damaged. Otherwise a modern OS like Windows 7 shouldn't fail loading USB drivers for a drive.

Start with changing the USB cable. If it doesn't help, you could try changing the casing, but I doubt that the inner electronics of the casing is the problem.

share|improve this answer

Have you tried useing the power button to turn off and then back on? I had a simular problem where I could not access the drive. It would appear in Eject External Devices, but not show up in Explorer. I turned it off, then back on, and there it was.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.