Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've read some of the other DHCP questions here, but my problem is a little different. I have a home laptop that has been working fine for ages. I brought my work laptop home at the weekend to finish a couple of tasks and connected it to my cable modem via ethernet cable - everything worked fine. Then I reconnected my home laptop, and it suddenly cannot find the dhcp server anymore. The IP address is (on both laptops) dynamically set, but even when I define a static IP address on my home laptop as being the dynamically assigned one on my work laptop (which worked OK), it still cannot get a connection.

I've tried ipconfig /flushdns, ipconfig /release and ipconfig /renew but it makes no difference. I suppose my network card on my home laptop could be defective, but would like to exhaust all other possibilities before I go down that route. Any ideas?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Have you tried resetting your cable modem? That would be my first recommendation. My second would be to reset your laptop if you haven't done so already.

share|improve this answer
    
a thousand thanks, my friend - that fixed it. I was a bit reluctant to shut it down as it's a new system and the telephone runs over the cable modem, too, but it did the trick. –  NogginTheNog Jan 20 '10 at 19:33
2  
A common method for cable modem providers to issue IP addresses is based on the MAC of the computer. (@home used the computer name) A modem will retain that MAC information for as long as it remains powered on. Thus, whenever you switch what you hook up tot he cable modem, it will need to be reset. –  DHayes Jan 20 '10 at 21:48
add comment

If you have any anti-virus/firewall/Internet protection programs loaded, ensure they haven't been set to block all traffic.

You may also want to try Safe Mode with Networking, as that should help rule out running software applications as a cause.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.