Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Pretty much what the title says, works fine in a plain (non-X) Cygwin window. It's probably a charset thing. In case it's related:

$ echo $LANG
C.UTF-8

I ungzipped the man page for less and the start looks like so:

.TH LESS 1 "Version 429: 11 Apr 2009"
.SH NAME
less \- opposite of more

Any ideas on how to fix this?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Use the mintty terminal or do 'alias man="LANG=C man"'.

share|improve this answer
    
urxvt-X also works. –  regjo Jan 21 '10 at 13:56

I fixed mine by setting my terminal (PuTTY) to UTF-8. PuTTY defaults to Latin-1 but Cygwin 1.7 now defaults to UTF-8. Check your terminal configuration.

http://turbulentsky.com/cygwin-funny-characters-man-pages-putty.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.