Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I edit files with emacs, emacs creates a file with the same name, but with a tilde on the end:

notes.txt~

When I save my changes and exit emacs, it doesn't remove the temp file. Is there a setting I can make in the .emacs that forces it to delete temp files so that it stops cluttering my directories?

share|improve this question
up vote 8 down vote accepted

Emacs calls these backup files (as opposed to temporary files starting with #). To not create these, add

(setq make-backup-files nil)

to your .emacs

share|improve this answer

What KeithB said, or put your files into version control.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.