Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A launchd item that was working in 10.5 is no longer working after my upgrade to 10.6. I am running 10.6.2 and I have recreated the launchd item and given it a new name and that one doesn't run either.

I have found a link of people with the same problem on google groups but none of the advice in that link helps. My launchd item is not listed in /private/var/db/launchd.db/com.apple.launchd/overrides.plist or in any of the overrides.plist files in the subdirectories of /private/var/db/launchd.db/

I have also tried to set this up as both a user agent and a user daemon.

My launchd item simply runs a shell script, which I have no problem launching manually.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>com.eric.tmnotify.launchd</string>
    <key>ProgramArguments</key>
    <array>
        <string>/<path_to>/tmnotify.sh</string>
    </array>
    <key>StartInterval</key>
    <integer>3600</integer>
</dict>
</plist>

I have tried to load it by overriding the disabled key (even though it is not disabled in any of the overrides.plist files) with both:

sudo launchctl load -F /Users/eric/Library/LaunchAgents/com.eric.tmnotify.launchd.plist
sudo launchctl load -w /Users/eric/Library/LaunchAgents/com.eric.tmnotify.launchd.plist

and after running either of them I can see that it is running by using sudo launchctl list but the shell script never fires.

Edit: I have also put this in the formerly blank file at /private/var/db/launchd.db/com.apple.launchd.peruser.501/overrides.plist :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
        <key>com.eric.tmnotify.launchd</key>
        <dict>
                <key>Disabled</key>
                <false/>
        </dict>
</dict>
</plist>

I also tried inserting this alphabetically:

    <key>com.eric.tmnotify.launchd</key>
    <dict>
            <key>Disabled</key>
            <false/>
    </dict>

into the file /private/var/db/launchd.db/com.apple.launchd/overrides.plist but still no dice.

share|improve this question
    
Have you checked system.log for any relevant messages? tmnotify.sh is executable? And a stupid question - but the user account 'eric' - it is logged in? –  Steve Folly Jan 21 '10 at 6:53
    
The account is logged in and the script is executable. There is nothing in the logs. –  ridogi Jan 21 '10 at 17:38
    
Have you looked at developer.apple.com/mac/library/technotes/tn2005/tn2083.html and the key LimitLoadToSessionType. I don't know if it'll cure your problem, but might be worth checking out. –  Steve Folly Jan 21 '10 at 19:59
    
I'll read through that some more, but it doesn't look like that applies to this problem. –  ridogi Jan 22 '10 at 23:16
add comment

1 Answer

up vote 0 down vote accepted

The release of Lingon for Snow Leopard in the Mac App Store solves this one.

share|improve this answer
    
One has to wonder what you are paying $4.99 for. Lingon 2.1.1 is free, open source, and works (find it on SF.net). MAS is selling 2.2. Somehow I doubt there have been any changes since 2.1.1. Perhaps you can request 2.2 source and compile it yourself, if there were any changes. –  user31752 Jan 17 '11 at 2:40
    
2.1.1 only supports up to 10.5. But the 2.2 release supports 10.6 –  ridogi Jan 17 '11 at 4:01
    
Do you know what Lingon did that was different and got the plist to work? –  Alan W. Smith Jul 31 '11 at 12:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.