Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My work has blocked Internet access with Firefox. I know how to change the value of “general.useragent.extra.firefox” through about:config, but when I try to change it to IE, I still can’t access any website.

I have Firefox 3.5.6 and Internet Explorer 7 installed on my desktop. Now, would I have to use the user agent that Internet Explorer 7 is currently using on my computer or can I use any Internet Explorer user agent? The user agent that Internet Explorer 7 is using right now is:

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022).

Do I just copy that and use it as the user agent in Firefox?

How can I make this work?

share|improve this question
1  
Are you sure that this is a User-Agent related problem, not simply the firewall blocking everything which comes from the app "Firefox"? –  Bobby Jan 21 '10 at 15:35
    
the firewall is probably installed on corporate gateway in this case –  whitequark Jan 21 '10 at 15:36
1  
@Bobby: Well, the firewall uses the useragent string to know which app is actually trying to get out. –  fretje Jan 21 '10 at 15:37
add comment

3 Answers

up vote 12 down vote accepted

That setting influences only a part of useragent string. Try the general.useragent.override one. This is what User Agent Switcher extension does. Tip: this setting may be not present in fresh install. You can create it with context menu.

Also, if you think you cannot install Firefox addons when it's not allowed to browse Internet, here's another tip: just go to Firefox's addon site site and download XPI extension archive; the just open it in Firefox with File -> Open menu and it will install!

share|improve this answer
2  
+1 I didn't even know not all the possible settings were available in about:config. Is there a list anywhere of what's all available? –  fretje Jan 21 '10 at 15:36
    
So, I create the "general.useragent.override" and place the Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022) value in it? –  wahle509 Jan 21 '10 at 15:38
1  
wahle509: right –  whitequark Jan 21 '10 at 15:40
    
    
Do you have a link to the "XPI extension archive" addon? –  wahle509 Jan 21 '10 at 15:49
show 2 more comments

Point your browser to about:config, right click, New -> String

Enter general.useragent.override and then

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022).

If your Firefox is completely blocked by the firewall, you should try some other Firefox-based browser like Flock. Flock can use any add-on posted on Mozilla add-ons homepage.

share|improve this answer
add comment

I don't know how to do this using about:config.

I do know you can easily do this with the User Agent Switcher add-on though.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.