Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I perform an action that is not valid in a given context, like attempting to type when a text area does not have the focus I hear a beep, which is very distracting when wearing headphones. How can I disable this?

I am not sure how to reproduce this as it only happens under certain circumstances which I have not yet nailed down.

share|improve this question

migrated from serverfault.com Jan 21 '10 at 18:33

This question came from our site for professional system and network administrators.

    
Hammer? (sorry, couldn't resist) –  squillman Jan 21 '10 at 18:34
    
Related‌​. –  Daniel Beck May 22 '11 at 17:03

4 Answers 4

up vote 13 down vote accepted

Apple, System Preferences, Sounds.

share|improve this answer
3  
Pedro's answer below is more useful, as the obvious setting when you do the above doesn't work. –  mahemoff Feb 19 '13 at 12:53

Unchecking the "User interface sounds" doesn't disable all sound. But sliding the "Alert Volume" option all the way to the left (minimum), together with unchecking the other options does the trick.

share|improve this answer

The OP mentions using headphones while using his/her computer, implying that he/she would like to disable the terminal bell but allow outher sound output to continue. Adjusting the sound settings in the system preference panel won't solve this problem.

Readline rings the bell at the command prompt in the terminal whenever the tab autocompletion can't find any matches, or finds too many matches. To disable just this behavior, check your home directory for the presence of a .inputrc. If doesn't exist, add it, then in either case add this line:

set bell-style off

Source this file

$ . .inputrc

or quit the terminal program and restart.

To completely disable sounds in the terminal, edit the apps preferences: Terminal menu, Preferences, Settings tab, then Advanced tab on that screen. There are two check boxes: audible bell and visual bell. Adjust to your tastes accordingly.

share|improve this answer
1  
Setting the alert volume to zero in System Preferences should actually disable the error sounds in Terminal as well. –  ؘؘؘ May 18 '12 at 18:56
1  
For whatever reason, sourcing the file did not help. Restarting the terminal did however. Thanks! –  user50849 May 13 '13 at 8:48

First, create a sound in the Library/Sounds directory in your home directory. This can be anything, but NOT one of the built-in sounds. Just grab something short from the internet. Use something you don't like. Honest.

Open System Preferences and click Sound to display its preferences. In "Choose an alert sound" pick the sound you just created.

  1. While you are in System Preferences | Sound, do the following:
  2. Uncheck "Play user interface sound effects"
  3. Uncheck "Play feedback when volume is changed"
  4. Uncheck "Play Front Row Sound effects"

After closing this window, go back to your home directory and DELETE the sound you just created. If you put it in the trash, empty the trash.

Now OS X will flash the screen slightly whenever an alert sound would have occurred. It is a subtle, but a sufficient alert. Now, sound in applications (like Cubase) will be completely unaffected.

share|improve this answer
1  
Cannot reproduce on OS X 10.6.7. @frabcus, did you test this? –  Daniel Beck May 6 '11 at 16:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.