Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do you change the resolution of the login screen in Ubuntu 9.10 (Karmic)?

Edit: keep in mind that I need to change the resolution of the login screen, as explained below.

share|improve this question
    
what is your login-manager (gdm, kdm, slick etc)? –  akira Jan 22 '10 at 4:55
    
I am using gdm. –  Nathan Osman Jan 22 '10 at 6:36

3 Answers 3

up vote 2 down vote accepted
+50

What you want to do is change the GDM LOGIN Screen resolution?

Read this and please accept the correct answer.

Justin was kind of correct except the fact that GDM uses the modeline from your xorg.conf. The priority runs from left to right, so if you add "1280x960" as the first entry and remove any items you don't want (who needs half of them anyway, 768x600 or whatever it was, madness.) you should be fine for GDM.

    SubSection "Display"
        Depth       24
        Modes       "1280x960" "1024x768"
    EndSubSection
EndSection

Let me know if you need further explanation.

share|improve this answer
    
This worked fine. Thanks :) –  Nathan Osman Mar 18 '10 at 0:20

I believe you need to configure your xorg.conf to include the proper modes.

edit /etc/X11/xorg.conf

Section "Screen"
    Identifier  "Default Screen"
    Device      "NVIDIA Corporation NV43 [GeForce 6600 GT]"
    Monitor     "17P3"
    DefaultDepth    24

    [...]

    SubSection "Display"
        Depth       24
        Modes       "1024x768" "1280x960" "640x480" "800x600"
    EndSubSection
EndSection

Where the first Mode is the default resolution.

If you have an ATI card you may try this as well.

sudo aticonfig --resolution=0,1280x1024,1024x768,800x600

Where 0 is the first screen, and the resolutions are in order of preferred first.

Try adding this as a subsection to the 'Screen' section in your xorg.conf

SubSection "Display"
        Virtual 1280 800
EndSubSection
share|improve this answer
    
...and this will just change the login resolution, right? –  Nathan Osman Jan 21 '10 at 19:11
    
Not really...resolution is a global setting. –  Bobby Jan 21 '10 at 19:25
    
That's not what I need though. –  Nathan Osman Jan 21 '10 at 19:40
    
Once I'm logged on, everything is fine, but the login screen has the wrong resolution. –  Nathan Osman Jan 21 '10 at 19:41
    
@George: Ohhh... in that case try it! I thought you wanted different resolutions and not the same, sorry. –  Bobby Jan 24 '10 at 18:21

If you don't have a special X11 configuration but you do happen to have a file /etc/X11/xorg.conf, you might want to try moving it aside and see what happens. Usually X11 should configure itself properly these days and in my experience having stuff in /etc/X11/xorg.conf often causes problems.

To try without the file:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

and restart.

If it doesn't help move it back:

sudo mv /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

and restart once more.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.