Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I normally use Pidgin (2.6.4 and now 2.6.5) on Ubuntu to connect to via XMPP for instant messaging. Yesterday, sometimes when I tried to connect, I would get the following error:

Unable to validate certificate

The certificate for could not be validated.
The certificate chain presented is invalid.

I have no idea why this is happening; other people in the same office are having no problem connecting to, and today it's happening every time. I tried removing the certificate for (in ~/.purple/certificates/x509/tls_peers/, and restarting Pidgin a few times, but no dice. I've tried every combination of settings I can think of (turning off TLS/SSL, allowing unencrypted streams, etc.) but nothing works. Any ideas?

share|improve this question

The problem is on the site, they are doing major changes and problems are to be expected for a few days. I have the same problems, don't worry.

share|improve this answer

Okay, I ran Pidgin on another machine, got the new current certificate, and copied it over to the old machine, and now I can connect. Still don't know why Pidgin wasn't able to notice that the old certificate was missing after I deleted it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.