Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install Ubuntu 9.04 64-bit version on VirtualBox, running in Windows XP. My PC is Dell Precision M2400 with Core2 Duo P8600.

After booting VirtualBox from Ubuntu ISO image and selecting the language and "install Ubuntu", PC reboots.

I've tested with different BIOS parameter combinations, but it didn't help.

Host OS is XP SP3 32-bit, and VirtualBox v3.0.8

share|improve this question

migrated from serverfault.com Jan 22 '10 at 12:17

This question came from our site for system and network administrators.

4 Answers 4

Does any other OS work as a guest?

I can't believe this would be a limitation, but does a 32bit version of Ubuntu work?

I would discount a hardware problem. You could use something like memtest86 to do a check of your memory to make sure it doesn't have a problem.

share|improve this answer
    
Yes, 32-bit Ubuntu works fine. –  tputkonen Oct 27 '09 at 11:31

The ideas I have had come to mind:

  • Check your RAM. It is possible, though somewhat unlikely, that you have a bad RAM block
  • Can you upgrade your VirtualBox version? As of this writing, the latest is 3.1.2 and there have been fixes that are certainly related to your scenario.
  • Have you tried enabling/disabling various VM settings? Specifically:
    • IO APIC
    • PAE/NX
    • VT-x / AMD-V
    • Nested Paging
    • Number of Processors

Turning all of those off and setting the processor count to 1 is probably the safest way (and least performant) to boot.

share|improve this answer

Although I don't know the particulars of your exact problem, here is a potential solution:

With Ubuntu Server 8.10 running under Virtualbox. First after installing Ubuntu Server 8.10 (Intrepid) the kernel failed to boot. It turns out that this was due to the fact that PAE/NX (Physical Address Extensions on the Host) are not enabled by default in the VM. To enable this you need edit the settings of your VM: Settings > General > Advanced > Extended features > PAE/NX.

share|improve this answer

The reason why XP reboots automatically is probably due to this setting

My Computer > Properties > Advanced properties > Reboot & recovery > "Reboot automatically on system error"

Try disabling it.

The reason of the system error is unknown though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.