Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

An old machine in our office, running Ubuntu 6.06 all of a sudden will not boot up. I get the following info during boot:

Uncompressing Linux... Ok Booting the kernel
mount: Mounting /root/sda1 /root failed: No such device
mount: Mounting /root/dev on /dev/.static/dev failed: No such file or directory
mount: Mounting /sys /root/sys failed: No such file or directory
mount: Mounting /pro /root/pro failed: No such file or directory
Target filesystem doesn't have /sbin/init

Busybox v1.01 (debian 1:1.01-4ubuntu3) Built-in shell (ash)

Enter 'help' for a list of built-in commands
/bin/sh: can't access tty; job control turned off

I haven't changed anything on the system as far as I'm aware, and I ran some HD diagnostics and everything seems fine.

After Googling around, I found this thread: Which seems very similar to my problem, however when I try to mount the drive with the following command:

sudo mount -t ext3 -o rw /dev/hda1 /mnt

I get the following error:

mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing code page or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

I ran fdisk -l and it says the partition type is Linux. I really have no idea where to go from here and would appreciate and thoughts.

The output after running dmesg | tail :

[12207.483801] init_special_inode: bogus i_mode (101)
[12207.483809] EXT2-fs: corrupt root inode, run e2fsck
[12260.427078] init_special_inode: bogus i_mode (101)
[12260.427086] EXT2-fs: corrupt root inode, run e2fsck
[13716.998799] e100: eth0 NIC Link is Up 100 Mbps Full Duplex
[13716.998923] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[13727.061967] eth0: no IPv6 routers present
[13896.700449] kjournald starting.  Commit interval 5 seconds
[13896.700458] init_special_inode: bogus i_mode (101)
[13896.700465] EXT3-fs: corrupt root inode, run e2fsck


After running e2fsck -p /dev/sda1, I get the following info:

/dev/sda1: clean, 142449 / 9584640 files, 5402711 / 19161520 blocks

Now I'm really not sure where to go with this :x

Thank you for looking

share|improve this question
Ubuntu suggests you that additional information may be found in output of dmesg | tail command, so can you post it too? – whitequark Jan 22 '10 at 17:40
Yes sir. I'll try to include it above. Thank you for your help. – Josh Jan 22 '10 at 19:45

You said it's an older might be ext2.

share|improve this answer
I ran it with ext2, but still shows the same thing unfortunately :-/. Thank you for the idea though :) – Josh Jan 22 '10 at 19:16
@Josh no worries...ooc, is reinstalling out of the question? Might be easier to reformat if there is no data on the system you need to recover. – AJ. Jan 22 '10 at 19:50
or pop in another hard drive and install a newer Ubuntu or Debian to that -- if there's any data recoverable off the old system drive, the new system drive should be able to find it. – quack quixote Jan 22 '10 at 20:30
I actually tried booting with the latest Ubuntu Live CD and putting the drive into another system and it still had trouble mounting the drive. There is some important data on the HD, so I would like to get to it if possible. Looking at the logs that I added to my original question it seems like the problem lies in the Superblock, which is a bit over my head at this point. From what I've been reading though, I maybe be able to restore it. Looking for a bit more feedback before I try it on my own, though. – Josh Jan 22 '10 at 20:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .