Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In power options the monitor is configured to turn off (go to power saving mode) after 10 minutes of inactivity. The problem is it also turns itself off when I watch long YouTube videos in full screen.

I like power saving, so the default behavior is OK, but it shouldn't kick in when I watch fullscreen videos.

Is there a way to fix it?

share|improve this question
Are you asking what your options are instead of changing the settings to never dim and/or turn the monitor off? – Mark Jan 22 '10 at 19:25
Yes, as I said I like the power saving stuff, so when I don't use the computer, it should turn off the monitor. But full screen video is a different story. It should detect if a full screen video is playing and it shouldn't turn off the monitor then. – Tom Jan 22 '10 at 19:34
But this is how it should work. Surely, lots of people watch full screen videos, it's a pretty common scenario, so there must be a better solution than simply disabling power saving altogether. – Tom Jan 22 '10 at 19:39
up vote 7 down vote accepted

But there is a workaround:

Make sure you use the Zen Jiggle mode to avoid any onscreen interference with your viewing pleasure.

share|improve this answer

Actually the software CAN ask windows to turn power saving off. Thats how media players do it. But when you watch youtube or other flash videos it is the browser that's running, nothing else. There is a flash plugin but this is a plugin, it only has access to the same things the browser has. If the browser does not provide access to power saving management the plugin can't access it. So the only way for that to be solved would be that browsers could have a new feature that would disable power saving when you visit some certain sites or has the ability to manage power saving and somehow passes that access to third party plugins. I don't see there is another way. or, you could go to the start menu and click on power options (search it) and then once your in you can click on a thing that let's you change how long until the computer goes into sleep mode.

share|improve this answer

I suspect there's some arcane reason that apps don't inherently have access to the power-saving settings, or it'd be a big no-brainer for Windows Media Player to have a "disable power saving" switch.

The best workaround I can think of is to set up 2 power-profile shortcuts, and remember to swap between them before & after watching video. It's hack, but it should work. Now all I need to do is figure out how to kick this in from across the network, when we're streaming from the DVR. ;)

share|improve this answer
I think it should work the other way around. Not the apps should be the ones who disable power saving, but power saving should check if an app runs full screen, and if so then it shouldn't turn off the monitor. I guess full screen needs some windows api call, so windows must know if an app is running full screen at any moment. – Tom Jan 22 '10 at 20:18
I would suggest this way as well but the only downside is the screen saver settings are separate. – MrStatic Jan 22 '10 at 21:39
You can automate this using Full Throttle Override, which will automatically switch the power-profile for you, when a specific application runs. See my full answer for details. (Note: I'm not affiliated with the tool in any way, I just used it to tackle the exact same problem :-)) – Marcus Mangelsdorf Nov 12 '15 at 12:22

Maybe it depends on the browser and the operating system, but I can tell you that using Firefox 32.0.1 in Windows 7 64-bit, whenever a sound is played by the Flash plugin, it prevents the display from turning off. This can be seen by running powercfg -requests while a sound is playing (run cmd.exe as an administrator before typing the command):

C:\Windows\system32>powercfg -requests
[PROCESS] \Device\HarddiskVolume1\Program Files (x86)\Mozilla Firefox\firefox.exe

[DRIVER] IDT High Definition Audio CODEC (HDAUDIO\FUNC_01&VEN_111D&DEV_76DF&SUBSYS_1028053F&REV_1002\4&313bea4d&0&0001)
An audio stream is currently in use.


Two things are shown in this example output. It's the firefox.exe process under DISPLAY: that is preventing the display from turning off. The sound playing through the audio driver prevents the system from going to sleep.

I consider Firefox's behavior undesirable, as I seldom watch long YouTube videos, and I don't want every message notification from Facebook Chat to turn my screen on. The behavior can be changed by using a powercfg -REQUESTSOVERRIDE command, like this:

powercfg -REQUESTSOVERRIDE process "\Device\HarddiskVolume1\Program Files (x86)\Mozilla Firefox\firefox.exe" display

Type powercfg /? for help.

share|improve this answer

Disable this "power saving feature" as it becomes counter productive whenever it turns off your displays while you're in the middle of watching a video/movie. Instead turn off your monitor and other displays using the power button on the display whenever you go AFK.

share|improve this answer

Maybe power saving looks for apps running in full screen mode but does not find any, because it's only the plug-in that's in full screen. Can you try setting the display mode of the browser to full screen (not maximized) before playing the video und check what happens then? Both Firefox and IE have full screen display modes.

share|improve this answer

You could also a small utility called Full Throttle Override to automatically switch power plans whenever the Flash Player (or your favorite video player) is launched. (I added FlashPlayerPlugin_16_0_0_296.exe, for example).

You just have to make sure to set Turn off the display to Never in your High performance power plan. (Unfortunately the app doesn't support to switch to a specified power plan other than High performance)

I had a short test run using mplayer.exe and the utility successfully switched to High performance and back to my default power plan while having a memory footprint of about 9.3MB (on Windows 8.1 x64)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .