Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox 3.6 has just been released and I am considering upgrading. The release notes state that:

When you install Firefox 3.6 all of your Extensions and Themes will be disabled until Firefox 3.6 determines that either a) they are compatible with the Firefox 3.6 release or b) there are newer versions available that are compatible.

I would like to know before I upgrade which add-ons will be disabled. It seems to me like there should be some tool that could tell me this. Any ideas?

share|improve this question
As an aside: using the "Nightly Tester Tools" ( one can override version restrictions (I use it to enable an old version of "keyconfig", to avoid problems with Cmd-Left on a Mac --…) – Arjan Jan 22 '10 at 19:52

1 Answer 1

Before the update starts it will list any updates that you have installed that will be disabled, and give you a chance to cancel.

From within Firefox, click help->check for updates.

share|improve this answer
Unfortunately, it did not. I tried running the installer and got no indication that any extensions would be disabled. After the install, one of my extensions is disabled. – staffan Jan 22 '10 at 21:17
Yours is an odd case because as Simon stated it did just this for me. It stated one of my themes and addons would not be compatible. – MrStatic Jan 22 '10 at 21:34
On a Mac, it would probably not warn you either, as installing is nothing more than dragging the new version into its place, overwriting the existing base program. (Next, upon first run, it will check what must be disabled.) Also, the release notes quoted in the question make me think one might not always be warned before installing. Of course, it's easy to downgrade again. – Arjan Jan 22 '10 at 21:48
No notice on the second computer I tried either. – staffan Jan 25 '10 at 19:10
Interesting. If you mention your old version and platform I'll update my answer to indicate this. If I think about it, this behaviour might be different on Linux too given the fact it might be handled by whatever package/update manager your distro is using. – Simon P Stevens Jan 25 '10 at 23:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.