Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So far I have unsuccessfully googled for HOURS with no luck fixing this very annoying problem.

The settings is the following:

  • I have PC running Windows 7 RC (64-bit)
  • Video card is a ATI Radeon 4850 series card (Sapphire HD 4850 512MB to be exact)
  • The video card has HDMI out with built-in audio chip
  • I have an HDMI cable connecting the PC to a TV (Sony Bravia series)

The problem is that when I connect the HDMI cable to the TV, the ATI HDMI Sound output device disappears completely from the list of playback devices in Windows.

As a workaround I can restore the audio by re-installing the HDMI audio driver. However, when I disconnect the TV the driver disappears again. So basically, every time I want to watch stuff on my TV, I have to reinstall audio driver, which of course is VERY annoying.

EDIT: I have figured out that I do not need to re-istall the HDMI audio driver to restore sound; I only need to reboot my computer with the HDMI cable plugged in to restore the audio driver. This suggests that the problem has something to do with information passed from TV to computer, which makes my HDMI Audio driver disappear.

Are there any other, more elegant workarounds for this problem?

share|improve this question

5 Answers 5

up vote 6 down vote accepted

I solved it!

You need to unplug the HDMI cable before you do this because the driver doesn't show up in the list if you don't.

  • If you locate the driver in "Properties", right click the speaker down by the clock on your desktop toolbar. Select "Playback Devices". There you should have the "Digital audio (HDMI)" icon.
  • Click it and select "Properties" at the next window. Again, select "Properties". Now you get to yet another window.
  • At the bottom left corner there's a button that says, "Change Settings". Click it and if UAC needs permission, then allow it. OK, another window, klick the "Driver" tab, here you should click the "Rollback Driver" button.
  • And when it is done, voila: HDMI sound again!

Long description, short fix: You can access this exact driver from Windows Device Manager too if you know which one it is.

So, now you can forget about getting those extra cables and rebooting your machine every time you want to use your HDMI output

My specs: Packard Bell laptop, ATI RADEON 4570 Chipset, Latest reference drivers from amd.com, Windows 7 Home Professional 32bit

share|improve this answer
    
As crazy as rolling back a driver sounds, it actually worked for me too! I don't fancy rolling back a driver everytime I want to use my HDMI sound, but honestly, its a better trick than rebooting. Thank you very much! –  jsalonen Aug 24 '10 at 18:41
    
I'm amazed: after applying this fix once, the problem doesn't seem to re appear. THANK YOU VERY MUCH!!!! – –  jsalonen Aug 30 '10 at 20:11

That sounds very annoying. How about leaving the TV connected all the time?

EDIT: Thanks for the clarification; now I understand a little better. You may be able to show hidden devices in Device Manager, then disable and re-enable the driver, but this still isn't much better than disabling the HDMI audio.

A better workaround might be to forget about the ATI HDMI audio device, and instead use the TOSlink or S/PDIF out from your sound card or motherboard, if your computer has one or both of those types of digital audio outputs. You can get long TOSlink and coax cables very cheap (I just bought a 25ft TOSlink cable for about $7 shipped from MonoPrice). Of course, if you don't need surround sound, you could use an equally inexpensive stereo RCA cable instead.

HDMI cables, on the other hand, are still very expensive. I'm looking at a similar wiring situation, but I haven't made a final decision yet where the TV and PC are ultimately going to be located. I'm looking at long cables from MonoPrice (some of the cheapest I've found) or Blue Jeans Cable (higher-quality cable certified for longer runs). I went ahead and bought the TOSlink cable because it's cheap enough that I can just buy a longer one later if I need it.

share|improve this answer
    
A problem is that the cable goes across the room: in order to make this work I would need to buy a new, much longer cable. The unfortunate truth is that this is the best solution so far :| –  jsalonen Jan 22 '10 at 22:37
    
Thank you for another good suggestion! The problem here is that my TV doesn't have separate ports for digital audio input. –  jsalonen Jan 23 '10 at 8:47
    
Sorry to hear your TV doesn't have a separate digital audio input, but if you're using the TV's built-in speakers, you can probably just use the analog stereo inputs on the TV without any noticeable degradation. –  rob Jan 25 '10 at 18:19
    
That is quite true, but if I'm required to by extra cabling I'll rather go and buy a longer HDMI cable as proposed. Ultimately I would love figuring out why the sound driver keeps disappearing, because that's actually the only problem with the current setup. –  jsalonen Jan 25 '10 at 21:24
    
Also note that I updated the original question: thanks to your tips I figured out that I do not need to re-install driver: only a re-boot with the HDMI cable on is enough the restore the sound. This also implies that buying a longer cable that stays on all time is the best workaround at the moment. –  jsalonen Jan 25 '10 at 21:37

I ran into the same issue when I connected a settop box through my AV receiver: when somebody had watched TV, the HTPC had lost its HDMI audio and instead I got a message that an SPDIF connection was detected. Rebooting indeed solved the issue, but only until someone turned on the settop box again.

On another forum (can't recall the name) I found the suggestion to disable the AMD External Events Utility in msconfig, which indeed seems to work for me until now and which also makes sense I think. So have a try if this helps? And if it does, credits to the other guy of course..

share|improve this answer

Found under Device Manager » ATI High Definition Audio Device. Right clicked and disabled/enabled.

This worked for me, it has something to do with plug and play. I'm running Windows 7 64-bit.

share|improve this answer
    
Yes, this is the way it should work, however it isn't! Thanks anyway. –  jsalonen Mar 16 '11 at 19:40

Same thing happened to me.

Click on speaker icon on the lower right hand side of your desktop:

enter image description here

Then click Playback devices.

Then Right click in the empty area of the list of devices, below all the rest of the devices, and click Show Disabled Devices:

enter image description here

Now you should see your disabled device:

enter image description here

share|improve this answer

protected by Troggy Feb 22 '11 at 5:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.