Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So the situation is that I have exactly one "normal" user account on my installation of Windows 7; Matt.

First question, is this an administrator account?

I have a number of small system tray apps that won't autostart. I have to run myself when I first need them because they need admin rights and apparently I can't have a program that needs admin rights automatically start up. So I get the UAC pop-up and have to click OK.

Question two, can I resolve this and just have it run? Without just turning off UAC. Unless that's a viable solution(?)

Lastly, I recently enabled the guest account. When I run one of the same system tray apps from the guest account it doesn't ask for permission! It just works! Since when does the guest have an easier ride than me?! Perhaps it's because I am an admin and Windows is trying to protect itself.

What can I do? I basically don't want to get so many UAC requests but don't want to turn it off altogether.

Cheers

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Answer to 1:

Probably. :)

If you're an admin and UAC is on it'll pop up and ask you to confirm actions that require Admin permissions. If you're not an admin it'll pop up and ask you for an Admin account name and password to allow the action.

I say "probably" becuase if you havn't done anything beyond the standard user created during install then Yes, it's an admin account.

To check - click the orb, and type "user a" (no quotes) into the search box and it should bring up "User Accounts" in the list as you type - hit enter to run it, or click it.

That should open a "Control Panel\User Accounts and Family Safety\User Accounts" window and it should tell you right there under your icon if your an Administrator or not.

Answer to 2:

The StartUp app is probably old and not Win7-ready because it's using some Admin-level function at startup, which as malware has shown us, is a bad idea - so Windows blocks it. You can approve it, but you have to do it at each logon.

Try to find an updated version of the program(s) that are being blocked.

Or you can remove it from how it starts now, and instead use the new Windows scheduler: create a new task and pick "Run at logon", as well as "run with highest privledges" (etc., there's lots of options you may decide you want) and it should start when you logon.

I found some good instructions on that here.

Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.