Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This has happened to me after a recent Security update from Apple. Went to restart, and Mac just hung for ages with pinwheel spinning. Eventually turned off at back of Mac Mini. Trying to reboot and it just hangs on grey screen with Apple logo and spinning grey dial.

I can boot into Windows using BootCamp not a problem, and I've tried entering Safe Mode on Mac by pressing Shift key. A grey bar slowly fills up about 1/3rd and disappears, leaving me with same grey boot screen with Apple logo & dial.

Anyone else experience this, or have any ideas how I can fix - please let me know.

share|improve this question

Resetting PRAM and NVRAM often solve issues like this, and it's certainly worth a try in this case.

Worst case scenario would be booting from the Snow Leopard disk and restoring your last backup, but let's not get ahead of ourselves.

This link from Apple describes more of the details, but essentially, you just hold down Command + Option + P + R after powering on the computer and before the grey screen appears.

This second link details what's stored in PRAM that will be reset to defaults.

If that doesn't work, and your computer still won't restart, this third link recommends attempting a restart while holding down Command + Option + Shift + Delete which will bypass the device that is selected in the Startup Disk control panel and boot from the first bootable device found.

share|improve this answer
I'll give it a go and mark it answered if I managed to get it fixed. – CannonGod Jan 23 '10 at 11:51

If you have a user replaceable battery - take it out, and hold the power button for upto 15 seconds.

This will reset pram. Should boot after that.

share|improve this answer
I don't quite understand what you mean regarding the battery. This problem is on a Mac Mini not a laptop (could you explain in more detail?). I've tried pulling out all the power leads over night to let capacitors run dry, and restarting after that. Are you saying I should still try holding the power switch on for 15 seconds? Does that act like a 'hard reset' on an iPhone? Will give it a try later. – CannonGod Jan 23 '10 at 4:13
Actually your comments have given me a good starting point to search through the Apple Support site. Looks like I can reset PRAM by holding the Command-Option-P-R keys during boot. Will give that a try, along with removing any/all USB devices. In all honesty I didn't think Macs would be this fiddly ^_^; – CannonGod Jan 23 '10 at 4:23
up vote 1 down vote accepted

Okay, I managed to get this resolved.

Tried all the various options suggested by people below but didn't work. In the end I called AppleCare and they informed I should reinstall Snow Leopard again. I wouldn't lose any files/BootCamp partition etc, but would need to carry out System Update again.

Simply insert Snow Leopard CD at boot and hold down the 'C' key. Will initiate reinstall which could take ~45 mins.

Case closed :)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .