Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a Nokia N810 running OS 2008 (version 5.2008.43-7; should be the latest). It can see networks up and down the street in my neighborhood and can connect to mine using WEP. I can also connect to free networks at restaurants and the like.

When I bring it into work, it can't see a wireless network ("No connections available"). When I use netstumbler on my laptop I can see a list of several essids showing green connectivity for the network. I know that the network has its essid broadcast, and I know that it's unsecured.

When I run iwlist wlan0 scan, I see several APs with no essid, but I don't see anything with an essid set. I have verified using iwlist that my hardware supports the correct channels and speeds.

I know this isn't a Nokia/mobile forum, but it's running what's basically a Debian kernel. Any suggestions on what to do in this case? I'm really frustrated by this.

Thanks, Nathan

share|improve this question
1  
whether it's an acceptable question has more to do with how you're trying to configure this; if you can access a commandline and tools i think it's ok, but if you're just using the standard Nokia GUI tools it's more of a phone question and i think you're better off on one of the smartphone q-and-a sites in this list: meta.stackexchange.com/questions/4/list-of-stackexchange-sites –  quack quixote Jan 23 '10 at 13:41
    
Thanks for the suggestion...I have access to a linux command line and toolset, including root access. –  Nathan Jan 23 '10 at 17:35
add comment

2 Answers

I don't know for the N810, but it seems like the N800 has problems accessing some Wifi channels.

share|improve this answer
add comment
up vote 0 down vote accepted

My premise was faulty.

I know that the network has its essid broadcast

Not actually true, apparently. When I manually entered the ssid, it worked fine.

Dur!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.