Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The /mnt/ext is mounted to an ext2 filesystem, an external hard drive. For some reason I can't run scripts from there. Please see the session below.

luntain@plato /mnt/ext $ echo "echo success" > k.sh
luntain@plato /mnt/ext $ chmod 777 k.sh
luntain@plato /mnt/ext $ ./k.sh
-bash: ./k.sh: Permission denied
126luntain@plato /mnt/ext $ ll k.sh
-rwxrwxrwx 1 luntain luntain 13 Jan 23 15:08 k.sh*
luntain@plato /mnt/ext $ 

I would love to find out why I see the error.

share|improve this question
add comment

3 Answers

up vote 9 down vote accepted

Probably there was a noexec attribute set when the filesystem was mounted; maybe it is your distribution 'feature'.

To check it you can execute mount that will show mount options in parentheses, and to remove noexec flag you can use mount -o remount,exec /mnt/ext under root.

Also, make sure you place the exec option after the user option, or the system will still mount your drive as noexec.

share|improve this answer
add comment

The file system is mounted with the noexec option.

share|improve this answer
add comment

A filesystem mounted noexec only prevents executing the script (i.e., asking the kernel to execute it appropriately based on a magic number or a shebang line). It doesn't prevent you from calling an interpreter on another filesystem mounted exec and passing the script as an argument (or on stdin) to said interpreter. Ergo, if not root, you could have worked around this with just sh k.sh.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.