Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have mapped drive S: on ThisComputer to \\ThisComputer\DocumentsFolder when I am attached to the network, and it works fine. Other computers on the network need to see this drive S: too, and are mapped in the same way.

When I am not connected to the network, I cannot access drive S:.

Is there a way to trick the computer into thinking I am attached to the network?

Using Windows XP.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I am surprised you wouldn't be able to do this as I used to do something similar.

This obviously won't help with other machines - you will want to take a look at Offline Files (Link 1 - nice guide, Link 2 - KB article).

For the local machine, you can trick it with the SUBST Command, simply type SUBST x: c:\test which should create a virtual X drive that is from c:\test,

If it is still failing, this is a guess - Do you have any firewall software that has roles e.g. when on different networks can configure different permissions? My guess would be that it could be blocking file sharing when on a network other than home/the default connection.

share|improve this answer
    
+1 the subst trick is probably easiest way to fix this –  whitequark Jan 23 '10 at 16:39
    
i feel flattered that you copied my link and refer to it as a 'nice guide'. –  Molly7244 Jan 23 '10 at 16:49
    
I made sure XP was fully up to date with the latest service packs, then went offline and turned off the firewall (ZoneAlarm) and now it works. I have since turned ZoneAlarm back on and it still works. Offline Files was turned on, but I checked that after I did the update. So thanks! :) –  Jelly Belly Jan 23 '10 at 18:50
    
+1 for subst, haven't used that in a while! –  John T Jan 23 '10 at 20:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.