Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Back to the time of Windows XP, from Properties dialog of my Wireless Connection, I can enable sharing and then select LAN network from the Drop Down List and boom, I can share it with my friend. We just need a LAN cable (either cross or not-cross is OK) and his Laptop will get an auto IP to gain access to internet.

But now with the new Windows 7, everything starts to suck. I cannot see the Drop Down List any more in the sharing panel and my friends Laptop cannot get an automatic IP anymore.

Am I doing anything wrong over there? How can I gain back the peace I used to have with Windows XP?

share|improve this question
    
"now with the new Windows 7, everything starts to suck." it's called 'progress' :) –  Molly7244 Jan 23 '10 at 17:40

1 Answer 1

up vote 0 down vote accepted

From the Windows 7 help on Internet Connection Sharing:

To enable ICS (Internet Connection Sharing), on your host computer:

  • Click to open Network Connections.

  • Right-click the connection that you want to share, and then click Properties. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

  • Click the Sharing tab, and then select the Allow other network users to connect through this computer’s Internet connection check box.

    Notes

    • The Sharing tab won't be available if you have only one network connection.

    • You can choose whether to select the Allow other network users to control or disable the shared Internet connection check box.

    • Optionally, to allow other network users to use services running on your network, click Settings, and then select the services you want to allow.

share|improve this answer
    
The Windows 7 behavior is a bit funny for me. If I enable some services in the Settings dialog, then the sharing will work as it should. But if I don't check any service, then there's no automatic IP anymore, the sharing won't work. Thanks. –  Phuong Nguyen Jan 24 '10 at 3:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.